User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Vectra 2.0DTi fuel pump failure

  1. #1
    New Member
    Join Date
    Dec 2012
    Location
    Haverhill
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectra 2.0DTi fuel pump failure

    Hi,

    I have a 2.0DTi vectra and coming down the A1 yesterday it cut out on me. It wouldn't fire up and the RAC came and fiddled on with parts and checked the fuses and the plug going into the fuel pump. He then sprayed something into another part of the engine and it fired up fine, he then went on to tell me that the fuel pump isn't working.


    After checking the price of this i have no intention of fixing the car, however somebody has told me that it could be an ECU fault which has caused the pump to shut down.


    Can anybody shed any light on this for me please?


    Cheers


    Dave

  2. #2
    Regular Member
    Join Date
    Feb 2010
    Location
    Wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Design

    Engine : 1.9CDTi

    Year : 2005

    Mileage : Lots

    Default

    I highly doubt it would have just started up fine on some easy start if the fuel pump was dead. More than likely a blocked fuel filter. Get that changed first and throw a litre of low ash 2 stroke oil in the fuel tank with a full tank of diesel to clean everything through.

  3. #3
    Regular Member Teapot's Avatar
    Join Date
    Mar 2010
    Location
    woodbridge, suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    103 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design+

    Engine : 1.9 CDTI 150

    Year : 2007

    Mileage : 101000

    Default

    Did it keep running after spraying easy-start, or did it just stop again after a few seconds? If it keeps running it is probably not the pump or ECU.

    I'm quite experienced on the electronics of this engine (and even repaired a failed pump control unit last year!)

    Were there any lights on the instrument panel when it cut out?

  4. #4
    New Member
    Join Date
    Dec 2012
    Location
    Haverhill
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cheers for advice,

    when he sprayed (something i cant remember the name of) into a black plastic bit in the engine he said that diesel cars can run on it and when he stopped spraying it the car cut out. He pulled another pipe off and there was no fuel coming through

    id lile to think it was an easier fix coz ive just had all the brake pipes done and a few other parts, wud be a shame to waste

  5. #5
    New Member
    Join Date
    Dec 2012
    Location
    Haverhill
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    There were no lights on when it cut out but when i kept trying to start it a spanner came on the dash

  6. #6
    Regular Member Teapot's Avatar
    Join Date
    Mar 2010
    Location
    woodbridge, suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    103 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design+

    Engine : 1.9 CDTI 150

    Year : 2007

    Mileage : 101000

    Default

    Sounds like it could be the dreaded pump control unit failure. But need to test properly before coming to conclusions. See your PM inbox...

  7. #7
    Regular Member macdad's Avatar
    Join Date
    Dec 2007
    Location
    East Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had similar on my dti although i was getting fault codes cant remember what it was though ,anyway one of the codes related to the actual pump and the other one was the crankshaft sensor,anyway the guy at the garage said it was most definitely the pump,however for the cost of the crankshaft sensor (£20 odd ) i decided to try one,fitted it and the car has been ok since ..worth a try hey...also check these out if it is the pump..http://www.ecutesting.com/vauxhall_b...iesel_pum.html

  8. #8
    Regular Member Teapot's Avatar
    Join Date
    Mar 2010
    Location
    woodbridge, suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    103 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design+

    Engine : 1.9 CDTI 150

    Year : 2007

    Mileage : 101000

    Default

    As I'm in the area I'm going to take a look at the op's car this weekend. crank sensor is on my suspect list...

    I remember seeing that website when the pump on my father's astra van died last spring. As I'm experienced in electronics I tested and repaired it myself, still going strong to this day.
    Last edited by Teapot; 29th January 2013 at 00:25.

  9. #9
    North West Regional Organiser paulvectrac's Avatar
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    nice one paul theres a how to thread some where were someone used a ford 1.8ttid pump from the scrapers tooknit apart used some bits to get theres goin again and its worked
    Vectra vxr custome remaps egr deletes dpf and diagnostic work all remaps are custome bench tuning avalible all genuine equipment PM for info

  10. #10
    Regular Member Teapot's Avatar
    Join Date
    Mar 2010
    Location
    woodbridge, suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    103 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design+

    Engine : 1.9 CDTI 150

    Year : 2007

    Mileage : 101000

    Default

    Quote Originally Posted by paulvectrac View Post
    nice one paul theres a how to thread some where were someone used a ford 1.8ttid pump from the scrapers tooknit apart used some bits to get theres goin again and its worked
    Sounds like a different fault (or he swapped the complete control unit from the donor pump to his - but I was told this usually requires a Bosch KTS to pair it with the ECU of the recipient vehicle).

    Usually its one of the output drive transistors that burns out. Repair of the existing control unit is usually possible by replacing this transistor with an uprated one but is a very intricate job as the tiny ceramic circuit board is of the 'in-open' design and covered in a protective gel.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 9th July 2012, 23:52
  2. Vectra C direct 2.2i fuel pump failure
    By davidu in forum Introduce yourself.
    Replies: 4
    Last Post: 19th September 2010, 23:58
  3. Fuel pressure sensor/fuel pump failure list following Watchdog investigation.
    By happychappy in forum Vectra C / Signum Car Chat
    Replies: 19
    Last Post: 14th January 2009, 13:18
  4. 2.0Dti fuel pump
    By wilf2312 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 5th December 2007, 01:22
  5. 1.9 CDTI 150 Fuel pump failure...help!
    By sri150 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 13th November 2007, 15:19

Visitors found this page by searching for:

vectra dti fuel pump failure

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •