User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: Another 150cdti spanner light

  1. #1
    Regular Member skip85's Avatar
    Join Date
    Feb 2010
    Location
    Wiltshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c estate

    Trim : Design

    Engine : 1.9 cdti 150

    Year : 2006

    Mileage : 150000

    Default Another 150cdti spanner light

    All,

    Spanner light stays on when I turn key before starting and all other lights go out as usual, then disappears after engine starts!!

    Any way of getting code before i have to take it to stealers to check codes?

  2. #2
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    Quote Originally Posted by skip85 View Post
    All,

    Spanner light stays on when I turn key before starting and all other lights go out as usual, then disappears after engine starts!!

    Any way of getting code before i have to take it to stealers to check codes?
    I'm prepared to say either glow plugs or the glow plug relay. Mine is the the same - it goes out after engine starts. Had the codes read and it's the relay on mine.

  3. #3
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP NAV

    Engine : 1.9 CDTi 150

    Year : 2007

    Default

    Quote Originally Posted by GazCDTI150 View Post
    I'm prepared to say either glow plugs or the glow plug relay. Mine is the the same - it goes out after engine starts. Had the codes read and it's the relay on mine.
    Do you get any actual issues with yours at all?

  4. #4
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    Quote Originally Posted by Dan_BlackSRi View Post
    Do you get any actual issues with yours at all?
    Starts perfectly even in the cold temperature we've seen. Think it's just a daft niggle tbh.

  5. #5
    Regular Member skip85's Avatar
    Join Date
    Feb 2010
    Location
    Wiltshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c estate

    Trim : Design

    Engine : 1.9 cdti 150

    Year : 2006

    Mileage : 150000

    Default

    Quote Originally Posted by GazCDTI150 View Post
    I'm prepared to say either glow plugs or the glow plug relay. Mine is the the same - it goes out after engine starts. Had the codes read and it's the relay on mine.
    So how much is relay and is easy to do? - would or could this lead to poor MPG all of a sudden before spaaner light came on

  6. #6
    Regular Member owen_999's Avatar
    Join Date
    Aug 2012
    Location
    Hartshorne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRI 150

    Trim : SRI

    Engine : 1.9cdti 150

    Year : 2007

    Default

    Mines doing similar it only goes out once I start the car. I bought it from a vx main dealer so assumed it was right. Might take it back to them and ask about it

  7. #7
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    Quote Originally Posted by skip85 View Post
    So how much is relay and is easy to do? - would or could this lead to poor MPG all of a sudden before spaaner light came on
    It may affect mpg on cold start. The relay sits right beside the battery box, on the engine side. Never changed it.

  8. #8
    Regular Member
    Join Date
    Mar 2012
    Location
    yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have the same problem too. fault on mine is one of the glowplugs not working correctly cant remember what the fault code was. no problems with cold start.

  9. #9
    Regular Member skip85's Avatar
    Join Date
    Feb 2010
    Location
    Wiltshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c estate

    Trim : Design

    Engine : 1.9 cdti 150

    Year : 2006

    Mileage : 150000

    Default

    Best take it to stealer but I will try relay 1st!

  10. #10
    Regular Member smartalec0310's Avatar
    Join Date
    Apr 2012
    Location
    littleport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    mine did this all it was was the car saying its got a fault on record got it cleared never came back!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Problems with Air bag light, ABS, Anti Skid & Spanner light
    By WeDesign in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 4th December 2012, 21:23
  3. Should I Have A Spanner Light aswell as an Engine Light on My Signum?
    By StreetDragster in forum Engine & Drivetrain
    Replies: 16
    Last Post: 18th August 2012, 11:57
  4. EGR Valve, Engine Management Light & Spanner Light
    By guygreen in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th December 2010, 20:09
  5. Spanner light 5 times now exhaust gas light
    By davieboy1976 in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 16th September 2009, 01:12

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •