User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: strange clicking sound?

  1. #1
    Regular Member
    Join Date
    Jan 2013
    Location
    yorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default strange clicking sound?

    as title when i turn ignition on i get a strange clicking noise from heater motor .now that wasnt there before i removed glovebox any advice folks? thx

  2. #2
    Regular Member
    Join Date
    Nov 2007
    Location
    Stourbridge
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    the clicking sound is hidden behind the underneath the panel on the right (as passenger sits. the right leg there is that side cover after you've taken the glove box off) take the other cover off or pull it away and you'll see and pinpoint the noise its a plastic white thing which you need to replace which interacts the direction of the air vents. hope that helps as i did my brother in laws 6 months ago.

  3. #3
    Regular Member
    Join Date
    Jan 2013
    Location
    yorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    exellent ill have a look in morning cheers

  4. #4
    Regular Member
    Join Date
    Jan 2013
    Location
    yorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    1 more thing rear nearside carpet wet ? could this be areial leaking ?or maybe door seal when i got car there was water in boot ?

  5. #5
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by ZAZ View Post
    the clicking sound is hidden behind the underneath the panel on the right (as passenger sits. the right leg there is that side cover after you've taken the glove box off) take the other cover off or pull it away and you'll see and pinpoint the noise its a plastic white thing which you need to replace which interacts the direction of the air vents. hope that helps as i did my brother in laws 6 months ago.
    Mine went about a year ago. Quite easy to fix

  6. #6
    Regular Member
    Join Date
    Jan 2013
    Location
    yorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quick update thx to advice on here I've now sorted. It. Cheers appreciated

  7. #7
    Regular Member john norris's Avatar
    Join Date
    Jun 2012
    Location
    lancashire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    where did you get the part to fix this?

  8. #8
    Regular Member
    Join Date
    Jan 2013
    Location
    yorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Scrappies

  9. #9
    Regular Member Steve E's Avatar
    Join Date
    Sep 2013
    Location
    Essex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    OK Sorry to bring this old thread up, but I think this is my problem - it started this morning.

    When I switch the ignition on there is a plasticky clicking noise from the central airvents or behind the radio display (not quite the heater motor). Sometimes it goes after a few seconds and other times it seems an age. But I'm guessing it's some plastic linkage to a vent flap, or something, jamming.

    Help?

  10. #10
    Regular Member
    Join Date
    Nov 2007
    Location
    Stourbridge
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Take the glove boxx off and the side covers and stick your head underneath get someone to turn the ignition on and you'll see the ticking noise very simple part to fix or swap.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. bizzare clicking sound upon starting
    By poppinch in forum Troubleshooting
    Replies: 8
    Last Post: 10th September 2012, 17:24
  2. Clicking sound when pushing on clutch
    By TonyTangles in forum Troubleshooting
    Replies: 3
    Last Post: 12th April 2011, 22:25
  3. Unlocking vectra- clicking sound
    By cribby in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 6th June 2010, 23:12
  4. strange clicking noise
    By pward in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 6th December 2009, 20:30
  5. clicking sound on unlock
    By big_dave in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 2nd March 2009, 17:28

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •