User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: z20net exhaust

  1. #1
    Regular Member richy1974's Avatar
    Join Date
    Jun 2012
    Location
    leek
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default z20net exhaust

    help please how many 02 sensors on a z20net exhaust system is there 2 or 3
    bit confused now as i was going to order a new 02 sensor for my vec as i keep getting sensor 2 bank 1 coming up as a fault.
    And he asked me which one it was i said sensor 2 and he said there was 3 on the vectra.

  2. #2
    Regular Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    there are 3 sensors in the exhuast in some, not all. Mine just had the two.. The first a lambda above the cat, the second is an EGT (exhaust gas temperature) sensor which is placed just below the cat.. The third sensor is the second lambda which is in the centre exhaust section.. The EGT is not required and can be mapped out.

    I have chnaged lambda 2 on mine... Becareful of cheap crap although they are all pretty much standard, look for a Bosch if possible..

  3. #3
    Regular Member richy1974's Avatar
    Join Date
    Jun 2012
    Location
    leek
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Caveman_nige View Post
    there are 3 sensors in the exhuast in some, not all. Mine just had the two.. The first a lambda above the cat, the second is an EGT (exhaust gas temperature) sensor which is placed just below the cat.. The third sensor is the second lambda which is in the centre exhaust section.. The EGT is not required and can be mapped out.

    I have chnaged lambda 2 on mine... Becareful of cheap crap although they are all pretty much standard, look for a Bosch if possible..
    cheers
    was looking at this one
    http://www.ebay.co.uk/itm/3307584278...84.m1438.l2649

  4. #4
    Regular Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    its certainly the correct sensor and will do the job... I think i paid less than half that for mine but cannot for the life of me remember where from..

    This sensor has 1.5m of cable and wires back to the engine bay, the other option is to cut the wires and solder/join the new one on down the exhaust system, this is what i did in the end..

    Btw this is no guarantee that your fault code will clear but you have to work through the process of elimination...

  5. #5
    Regular Member richy1974's Avatar
    Join Date
    Jun 2012
    Location
    leek
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have been getting the fault ever since i had the custom exhaust fitted so i hoping that all it is a dogy sensor.
    Car as done 90000 so i would think a sensor would be duff at this millage

  6. #6
    Regular Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    yeah fair enough.. run with it, I would..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Z20NET Exhaust
    By philc1210 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 4th August 2012, 14:10
  2. signum z20net engine.my exhaust.
    By rayeg1935 in forum Bodywork & Interior
    Replies: 1
    Last Post: 22nd March 2012, 10:31
  3. Z20Net Lonlife stainless Exhaust
    By Keefyb007 in forum Petrol Engine related
    Replies: 12
    Last Post: 24th January 2012, 16:06
  4. Z20Net Exhaust
    By Turbovec in forum Petrol Engine related
    Replies: 15
    Last Post: 15th April 2011, 09:11
  5. Exhaust on a 2.0t z20net Help and advice
    By dawasdave in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 26th February 2010, 21:13

Visitors found this page by searching for:

vectra c exhaust gas temperature sensor

z20net exhaust gas temperature

z20net temperatur

z20net exhaust problem

z20net exhaust gas temperatur

z20net exhaust temperature sensor

z20net exhaust centre section

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •