User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: A code P0138 z20net

  1. #1
    Regular Member richy1974's Avatar
    Join Date
    Jun 2012
    Location
    leek
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default A code P0138 z20net

    hi guys help please keep getting this code on my z20net p0138-02 sensor circuit high voltage bank 1 sensor 2 . What i want to know is where the best place to get a sensor from and is the one underneath the car thanks for looking any help would be appreciated

  2. #2
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Sensor 2 yes.

    i would first suggest checking that your problem lies in O2 sensor and not the fact its a lean condition causing a rich command

  3. #3
    Regular Member richy1974's Avatar
    Join Date
    Jun 2012
    Location
    leek
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Critch View Post
    Sensor 2 yes.

    i would first suggest checking that your problem lies in O2 sensor and not the fact its a lean condition causing a rich command
    yes mate sensor 2
    how do i check for lean condition its be doing it since i have a a new custom stainless steel zorst fitted

  4. #4
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Quickest way is to watch on live data whilst squirting some carb cleaner into intake.

    that should start making it rich. You should see it switch to lean command in under 100ms

    If its been doing it since exhaust fitted check connection and wiring haven't been damaged.

    Chances are it is a knackerd sensor. But it's always worth checking everything. Last thing you want to do is chuck 100+ pound at a part plus labour to find faults still their

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Error code reading and code readers
    By Ben50n in forum Engine & Drivetrain
    Replies: 14
    Last Post: 27th August 2012, 16:43
  2. P0138 Fault : Siggy drinking petrol. Help Please
    By Envy in forum Engine & Drivetrain
    Replies: 22
    Last Post: 25th April 2012, 22:18
  3. assistance with fault code please (z20net)
    By chesh1980 in forum Engine & Drivetrain
    Replies: 8
    Last Post: 8th March 2012, 22:26
  4. Replies: 1
    Last Post: 27th November 2011, 17:09
  5. Fault codes P0138 & P0141 O2 sensor
    By trampd1 in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 8th August 2007, 10:43

Visitors found this page by searching for:

p0138 vauxhall vectra

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •