User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: temp gauge problem or not ?

  1. #1
    Regular Member madmark's Avatar
    Join Date
    Feb 2008
    Location
    great yarmouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default temp gauge problem or not ?

    hi i just got a 2007 cdti vectra and it takes ages for the tepm gauge to move up but the heaters do blow warm air after about 20 mins driving the gauge goes up to atound 75c but once on a open road it drops again then rises is this normal ? thank you

  2. #2
    Regular Member tditony's Avatar
    Join Date
    May 2009
    Location
    durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2007 sri xpnav

    Trim : sri xpnav

    Engine : 1.9 150

    Year : 2007

    Default

    i would say thermostat stuck open mate new one required

  3. #3
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXR8 6.0 muscle SRI ESTATE XP1

    Trim : VXR/ SRI ESTATE CDTI XP1

    Engine : 6.0 V8 Thunder

    Year : 2008

    Default

    your thermostat is on its last legs fella very common on the vec c diesels some change it and swear by better MPG some dont bother and say it dont make a difference im in the former camp bud
    VXR IS FOR LIFE NOT JUST FOR THRILLS !



  4. #4
    Regular Member Albert99's Avatar
    Join Date
    Nov 2012
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Bet ya!

    Bought a Siggy 1.9 CDTI 150 Facelift... Nearly froze to death. Changed thermostat and now it warms up quick, stays at 86 ish degrees all the time and heaters are mental hot.

    A

  5. #5
    Regular Member madmark's Avatar
    Join Date
    Feb 2008
    Location
    great yarmouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thank you all for the fast replys change it i will cheers mark

  6. #6
    Regular Member
    Join Date
    Jan 2012
    Location
    Silverstone village
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by madmark View Post
    thank you all for the fast replys change it i will cheers mark
    If you have the 1.9 120 cdti then please be warned it is a pig of a job, as the egr cooler bracket has to be removed or preferably cut off as many including myself have done, the 150 does not suffer from this design problem, so finger crossed you have the 150.

  7. #7
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : SRI

    Engine : CDTI 150 (Z19 DTH)

    Year : 2008

    Mileage : 100k

    Default

    Quote Originally Posted by mon View Post
    If you have the 1.9 120 cdti then please be warned it is a pig of a job, as the egr cooler bracket has to be removed or preferably cut off as many including myself have done, the 150 does not suffer from this design problem, so finger crossed you have the 150.
    LOL - done both a good few times and yip - the 120 is a bit of a design flaw!!..

    As others have said - defo Thermostat fault. they fail open causing the engine not to warm correct.

  8. #8
    Regular Member madmark's Avatar
    Join Date
    Feb 2008
    Location
    great yarmouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i have the 120 lol but there u go needs doing thanks for the warning will do it once it warms up abit out side as car is warming up enougth to use for a week or so then i sort it

  9. #9
    Regular Member
    Join Date
    Jan 2012
    Location
    Silverstone village
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by madmark View Post
    i have the 120 lol but there u go needs doing thanks for the warning will do it once it warms up abit out side as car is warming up enougth to use for a week or so then i sort it

    Be sure to have a read on the forum , the thermostat is held on by the egr cooler bracket, and I would strongly advise cutting the bracket, I got an angle grinder on mine in the engine bay, so not for the faint hearted, a nerve racking job.

    I would wait until the spring to do it...

  10. #10
    Regular Member madmark's Avatar
    Join Date
    Feb 2008
    Location
    great yarmouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yer good idear lol the car is warming up so will leave it untill weather clears abit thank you all for your posts on this problem

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.2 se water pump/ temp gauge problem.
    By james chambers in forum Engine & Drivetrain
    Replies: 4
    Last Post: 29th June 2012, 20:31
  2. 2.2 se water pump/ temp gauge problem.
    By james chambers in forum Engine & Drivetrain
    Replies: 15
    Last Post: 19th January 2012, 02:13
  3. z18xer temp gauge problem
    By amd in forum Engine & Drivetrain
    Replies: 1
    Last Post: 30th June 2011, 19:19
  4. rev counter/speedo/temp gauge/fuel gauge stopped working
    By bloodworm in forum Electrical & ICE (including SatNav)
    Replies: 13
    Last Post: 19th July 2009, 00:28
  5. Temp gauge problem?????
    By stubopvectra in forum Engine & Drivetrain
    Replies: 4
    Last Post: 4th March 2008, 21:31

Visitors found this page by searching for:

vectra takes ages to warm up www.vectra-c.com

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •