User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: HID Direct - returns?

  1. #1
    Regular Member
    Join Date
    Sep 2011
    Location
    lewes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 1?? - Teapot mapped

    Year : 2006

    Mileage : 125000

    Default HID Direct - returns?

    What are HID Directs like with returns?

    I received their new Slim smart canbus kit today and proceeded to fit it.

    Unfortunately one of the ballasts didn't work. I swapped them over to confirm the fault.

    I am hoping it will be as simple as sending the faulty one back and receiving a new one? Or will this not be the case

  2. #2
    Full Member RBH's Avatar
    Join Date
    Jan 2008
    Location
    North Lanarkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    81 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VECTRA

    Trim : SRI XP NAVI

    Engine : 1.8 vvt

    Year : 2008

    Mileage : 73,166

    Default

    good luck mate.

    ome guys have not had any issue with them, but others including myself have had some issues.

    my opinion is they're not good to trade with.

  3. #3
    Regular Member
    Join Date
    Sep 2011
    Location
    lewes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 1?? - Teapot mapped

    Year : 2006

    Mileage : 125000

    Default

    Quote Originally Posted by RBH View Post
    good luck mate.

    ome guys have not had any issue with them, but others including myself have had some issues.

    my opinion is they're not good to trade with.
    Hmmm ok. It should be a very simple process.

    I decided to pay by a credit to give me some protection.

    Anyway, fingers crossed I will get lucky

  4. #4
    Regular Member Exclusive BV's Avatar
    Join Date
    Apr 2010
    Location
    West Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i got the same kit mate, fitted today. i just cant beleive how many of these ballasts arrive not working.

    btw did you try the spade connectors both ways around?

    neither of mine were working at first but when i swapped the red and black over they both worked ok

    good luck with the return

  5. #5
    Regular Member
    Join Date
    Jan 2012
    Location
    Dublin
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats


    Trim : SRi

    Engine : Z19DTH


    Default

    Chinese ballasts / parts for you... They either work or they dont. Think i'll be giving HID's Direct a miss, lol was going to buy from them but so many people on here seem to be having trouble with their parts and rubbish customer service

  6. #6
    Regular Member john norris's Avatar
    Join Date
    Jun 2012
    Location
    lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have a kit from them they sent the wrong bulbs but thats being sorted ballast are top level product with aluminium case not like cheap plastic makes

  7. #7
    Regular Member 06sri's Avatar
    Join Date
    May 2012
    Location
    northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    if bought online and faulty your are entitled to a full refund, plus a refund of the postage you pay to send it back, or a replacement and a refund of any postage costs you incur.

  8. #8
    Regular Member Graham's Avatar
    Join Date
    Sep 2005
    Location
    Macclesfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Focus

    Trim : Titanium

    Engine : 1.6 TDCI

    Year : 62

    Mileage : 9K

    Default

    Still waiting for my refund. Sent me out a new ballast so i paid £15 deposit until i send the old one back. Did this early Dec last year, still no money in my account. Sent email last week and recieved their xmas opening times .
    Will try ringing them tommorow.
    Their after service is not very good.

  9. #9
    Regular Member
    Join Date
    Sep 2011
    Location
    lewes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 1?? - Teapot mapped

    Year : 2006

    Mileage : 125000

    Default

    Quote Originally Posted by Exclusive BV View Post
    i got the same kit mate, fitted today. i just cant beleive how many of these ballasts arrive not working.

    btw did you try the spade connectors both ways around?

    neither of mine were working at first but when i swapped the red and black over they both worked ok

    good luck with the return
    I didn't change the spade connectors arounds, I just assumed they would be put together correctly and both sides would install the same!! The side that worked was definitely a red positive wire.

    Its all packed up and ready to go in the post tomorrow but I may take it out and try it with them swapped over.

  10. #10
    Regular Member Exclusive BV's Avatar
    Join Date
    Apr 2010
    Location
    West Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    it's the spades that plug into the original headlight connector. on my kit they were black and red. For some reason on mine they only worked if connected a certain way round

    hth

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. An old member returns.... Hello :)
    By chrisdownes in forum Introduce yourself.
    Replies: 14
    Last Post: 24th August 2011, 23:58
  2. The vectra returns!!!
    By redross555 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 15th January 2011, 21:13
  3. The Vectra Returns
    By discco in forum Introduce yourself.
    Replies: 14
    Last Post: 25th February 2009, 21:44
  4. Deathwish Returns
    By VauxVeteran in forum The 'Off Topic' room
    Replies: 0
    Last Post: 11th March 2008, 03:02
  5. EML returns....
    By parapaul in forum Engine & Drivetrain
    Replies: 3
    Last Post: 3rd July 2007, 07:20

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •