User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Z30DT fail to start

  1. #1
    New Member
    Join Date
    Oct 2012
    Location
    Bucharest
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Z30DT fail to start

    Could you please help me to diagnose my Z30DT engine (2007, 140.000 km)?
    Day 1 (in the morning): motor started at the first key and run for 20-30 sec then stopped. After 4-5 keys, engine started again and run smoothly for the rest of day.
    Day 2 and 3: exactly the same symptoms (stopped after the first start in the morning then, after few tries started again and run smoothly for the rest of the day)
    Day 4: motor started, running for the same 20-30 sec then stopped and completely refuse to start again.

    I used the OP-COM to read the engine faults:
    CIM: B3700, B3794
    ECM: P0100, P1070, P1565
    AIRBAG SDM: U2139
    BCM: B2652
    DDM: B3902, B1640

    After 3 weeks of checking, a specialist said that he is not sure, but he think that I have to replace the fuel rail.
    What do you thing? Any other idea?
    Many thanks.

  2. #2
    Regular Member
    Join Date
    Jan 2011
    Location
    lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    CIM fault would stop the car from starting pal

  3. #3
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    Could be fuel draining back tonthe tank cause of air leak or fuel filter.

  4. #4
    New Member
    Join Date
    Oct 2012
    Location
    Bucharest
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by bembo449 View Post
    CIM fault would stop the car from starting pal
    In the first days, the engine started and running for 20-30 sec. This could be also from CIM?

    Quote Originally Posted by mattv6diesel View Post
    Could be fuel draining back tonthe tank cause of air leak or fuel filter.
    These were checked, no problems here.

  5. #5
    Regular Member
    Join Date
    Jan 2011
    Location
    lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    it does actualy read like EDU failure like the 2.2dti suffer with , its the ECU on the fuel pump , if its starts and runs fine by spraying easy start down the inlet , then my money would be on a fuel / pump issue

  6. #6
    New Member
    Join Date
    Oct 2012
    Location
    Bucharest
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I could not identify EDU on this the parts list (http://ecat24.com/opel/catalog/part/...07/4281/42780/). Is available as separate part or shall I replace the entire fuel rail?

  7. #7
    Regular Member
    Join Date
    Jan 2011
    Location
    lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    im not mega familiar with the 3.0 derv unit but it appears most derv cars have an EDU , normally on top of the pump itself , its not cheap to replace new , refurbs are possible now but as i said , you'd have to look into this for the 3.0derv , you need to get the garage to see if it will start as i posted before first matey

  8. #8
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    33 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mk1 renault scenic... I know I know but it drives

    Trim : Basic

    Engine : 1.6 16v

    Year : 2003

    Default

    Clamp fuel pump return pipe and see of it starts and runs

    whats fuel pressures like?

    Check fuel filter is full

  9. #9
    Regular Member nutron's Avatar
    Join Date
    Jul 2005
    Location
    South Central England
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall

    Trim : very

    Engine : Z19DTH

    Year : Nosey

    Default

    Common rail engines don't have a fuel pump controller like the old 2.2DTI, so that rules said out. If it starts and then stops it is not likely to be the pump, as I would not think it would make enough pressure to inject even at idle. I be looking at wiring or a CIM or even the ECU based on the number of fault codes. Don't waste time with mobile mechanics or local garages, if you want the fuel system checked take it to a diesel pump specialist.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Z30DT DPF Re-Gen
    By ben_3.0v6 in forum Y & Z30DT Specific
    Replies: 3
    Last Post: 3rd January 2012, 21:37
  2. 1.9 150bhp wont start after water pump and cam belt fail
    By richsimpson in forum Engine & Drivetrain
    Replies: 4
    Last Post: 12th March 2011, 15:53
  3. 1.9cdti wont start following waterpump/belt fail
    By richsimpson in forum Engine & Drivetrain
    Replies: 2
    Last Post: 9th March 2011, 19:57
  4. 2.2DTi - Cold start fail at -1°C
    By Celes in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 11th March 2010, 13:58

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •