User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Heater / Blower Not Working Properly (2006 Vectra 1.8)

  1. #1
    Regular Member bigboynigs's Avatar
    Join Date
    Oct 2007
    Location
    ALDERSHOT
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Heater / Blower Not Working Properly (2006 Vectra 1.8)

    Hi all, I have a 2006 Vectra Exclusiv which up until the other day was fine, now the blower has decided to go either all or nothing i.e. 1,2 & 3 setting nothing happens but full blast on 4 it is fine.

    Everything else works fine, temperature, changing of direction of blowers from screen to floor etc. Not really very electrically minded so help appreciated.

    Bit of a pain in the **** having to turn fan on as fogging up, turn it off as sweating too much, on again as fogging.........etc, etc

    Cheers

  2. #2
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXR8 6.0 muscle SRI ESTATE XP1

    Trim : VXR/ SRI ESTATE CDTI XP1

    Engine : 6.0 V8 Thunder

    Year : 2008

    Default

    sounds like your heater motor resistor has gone fella theres tons of threads on here about it the search box is your friend
    also make sure your scuttle panel drains are clear again lots of threads about that too
    VXR IS FOR LIFE NOT JUST FOR THRILLS !



  3. #3
    Regular Member
    Join Date
    Jul 2010
    Location
    This is London baby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Dodge Journey

    Trim : SXT

    Engine : 2.0Tdi (VW Engine)

    Year : 2010

    Mileage : 53000

    Default

    Could also be the blue relay (this controls speed 1,2 & 3) behind the glovebox.

  4. #4
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    as already said... due to the scuttle drain being blocked it will have filled with water & found it's way down passed the pollen filter onto the heater resistor pack... remove/replace pollen filter (my guess is it's wet) clear scuttle drain or just remove the bung altogether & replace resistor

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Heater Fan Blower. Vectra C
    By Milden in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 14th October 2012, 20:22
  2. Heater Blower not working on Climate Control Model
    By wifesgotasignum in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 14th June 2012, 09:54
  3. wanted heater blower motor vauxall vectra c
    By Les45 in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 24th May 2011, 08:21
  4. Heater blower stopped working
    By owb82 in forum Vectra C / Signum Troubleshooting
    Replies: 2
    Last Post: 24th September 2009, 18:24
  5. Heater blower has stopped working
    By Dave1971 in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 3rd September 2008, 12:55

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •