User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: 54 plate vectra 2.0 DTI engine management light on

  1. #1
    New Member
    Join Date
    Dec 2012
    Location
    scunthorpe
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default 54 plate vectra 2.0 DTI engine management light on

    hi all,
    my vectra 54plate 2.0 DTI engine management light on all the time runs like a bag of spanners smokes like mad when you put you foot down and is well down on power,
    Took it to garage they said fault was air flow metering unit but they tested it and said was ok re-set the light all was good then light on again. anyone got any ideas where to start?

  2. #2
    Regular Member Signum-Steve's Avatar
    Join Date
    Feb 2009
    Location
    Cramlington Northumberland, V6 Jaguar S-type Sport
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    The first thing i would do is check the vacuum pipework for splits and cracks. They are renowned for perishing over the years. Also check all your boost/inter-cooler pipework.
    When checking the boost pipe/inter-cooler pipework get someone to rev the engine while you take a look. You will see the pipework expand. It will give you a good chance to feel for or see/hear the splits if there are any present. When checking the vacuum pipe work pay particular attention to the rubber elbows and joints. these perish and split/crack. The one that fits onto the turbo actuator takes a lot of heat so can become very brittle.

  3. #3
    New Member
    Join Date
    Dec 2012
    Location
    scunthorpe
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    cheers steve gunna have a good look over it i checked intercooler pipe work a while back all looks good was thinking of just changing all the vacum pipes & elbows see if that helps will i need to get the light re-set to make a differance or will it run ok if the vac pipes are the problem?

  4. #4
    Regular Member Signum-Steve's Avatar
    Join Date
    Feb 2009
    Location
    Cramlington Northumberland, V6 Jaguar S-type Sport
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Once the vacuum has been restored the light should ho out.
    if its not inter-cooler or vac related my next step would be a strip and clean of the upper TB and the EGR valve. I would still check all the pipework thoroughly first. to rule things out step by step.

    which light have you showing? I assume its the car spanner?

  5. #5
    New Member
    Join Date
    Dec 2012
    Location
    scunthorpe
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    no its the engine hazard bottom right in dash

  6. #6
    Regular Member Signum-Steve's Avatar
    Join Date
    Feb 2009
    Location
    Cramlington Northumberland, V6 Jaguar S-type Sport
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    You will need to get your codes read to pin point the problem

  7. #7
    New Member
    Join Date
    Dec 2012
    Location
    scunthorpe
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    cheers steve gunna change out all vac pipe so rules that ok sick of paying garage £40 a time with no results

  8. #8
    Regular Member Signum-Steve's Avatar
    Join Date
    Feb 2009
    Location
    Cramlington Northumberland, V6 Jaguar S-type Sport
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Yeah rule the simple stuff out first.
    There might be someone with a code reader in your area to read your codes hopefully.

  9. #9
    Regular Member
    Join Date
    Jan 2007
    Location
    Chelmsford
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by danny 77 View Post
    cheers steve gunna change out all vac pipe so rules that ok sick of paying garage £40 a time with no results
    Pick yourself up an ODB reader from ebay like this one...

    http://www.ebay.co.uk/itm/Car-Diagno...item416f736f3a

    Cost half as much as a trip to the garage...

    I picked up a rock bottom one a few years ago for about £15... Most basic thing in the world, but it's a god-send when it comes out to finding where the faults are...

  10. #10
    Regular Member wingi's Avatar
    Join Date
    Dec 2012
    Location
    clipstone
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    what p codes did the garage find? was the fault discription (mass air flow deviation)! if so it would appear you have the same fault as me on my 2.2 dti! no power (turbo no coming in) wont rev over 2500 prm eml on. near your battery there is a black rectangle box vacuum reservoir disconnect the pipe from it and you should hear a hissing sound if this is the case you do have vacuum! leave this disconnected and road test to see if turbo comes in and car drives ok.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra c engine management light
    By Mark Curran in forum Engine & Drivetrain
    Replies: 4
    Last Post: 16th May 2011, 11:39
  2. Vectra c engine management light on and no power
    By Mark Curran in forum Engine & Drivetrain
    Replies: 6
    Last Post: 13th May 2011, 15:28
  3. vectra 2.2 engine management light
    By jonahstfc in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 26th October 2010, 15:46
  4. Replies: 3
    Last Post: 28th April 2009, 19:49
  5. Vectra B 2.2 SRI DTI Engine Management Light
    By Vaux-Man-G in forum Engine & Drivetrain
    Replies: 9
    Last Post: 10th January 2008, 19:08

Visitors found this page by searching for:

eml on vauxhall vectra c 2.0 dti

eml on all the time vectra c

2004 vectra c 2.0 dti ecu light on

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •