User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: Engine hesitating and generally lacking power

  1. #1
    Regular Member
    Join Date
    Sep 2010
    Location
    Leyland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Engine hesitating and generally lacking power

    My 1.8 VVT has just recently been lacking power and hesitating. I'm planting my foot to the metal but m speed decreases (motorway driving). Round town it's still evident but not to the same degree.

    I run on LPG (done about 25k so far) without any problems. The problem only seems to be happening when running on gas. If I switch to petrol, it goes away.

    The EML has come on and that's giving me 0301 - 0304 (all 4 cylinder misfires detected). Also a 0170 fuel correction dysfunction (assume its related to the misfiring).

    Im changing the LPG fuel filter and plugs tomorrow. Fingers will then be crossed to see if it works....if not, I assume it could be a coil pack failure...

    Any other suggestions?

  2. #2
    Regular Member
    Join Date
    Feb 2010
    Location
    Wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Design

    Engine : 1.9CDTi

    Year : 2005

    Mileage : Lots

    Default

    Could be either for now. Gas needs a stronger spark than petrol so start with fresh plugs and gas filter then work from there. It's unusual for the coilpack to go and ALL cylinders misfire though so sounds like a fuel starvation problem.

  3. #3
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mk1 renault scenic... I know I know but it drives

    Trim : Basic

    Engine : 1.6 16v

    Year : 2003

    Default

    Look at fuel trim. You'll more than likely find its down to fuel.

    a coil pack to break up on all four cylinders very uncommon

  4. #4
    Regular Member Ben50n's Avatar
    Join Date
    Dec 2011
    Location
    Seaham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    When were the plugs last changed?? Also check the air filter and do the air box mod.

  5. #5
    Regular Member
    Join Date
    Sep 2010
    Location
    Leyland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I'd say plugs have been in for around 15-20k. I've done the air box mod and changed the air filter last week (only the OEM filter, not a K&N - someone needs to convince me I need to shell out that amount!).

  6. #6
    Regular Member
    Join Date
    Feb 2010
    Location
    Wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Design

    Engine : 1.9CDTi

    Year : 2005

    Mileage : Lots

    Default

    Sounds like a gas filter then. Have you ever changed it or is there any record of it being changed?

  7. #7
    Regular Member Ben50n's Avatar
    Join Date
    Dec 2011
    Location
    Seaham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Let us know how you get on after changing the plugs.

  8. #8
    Regular Member
    Join Date
    Sep 2010
    Location
    Leyland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Apparently the gas filters are only changed every two years, so march 2013 would have been its first change. I'll report back when ive changed both tomorrow.

  9. #9
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : ls

    Engine : 1800

    Year : 04

    Mileage : 133000

    Default

    I would go with changing the plugs first

    Sent by nexus 7

  10. #10
    Regular Member
    Join Date
    Sep 2010
    Location
    Leyland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Plugs have been changed this morning. Was hoping to do the fuel filter at the same time but it ain't arrived yet. I'll road test on the way to work and see how it feels.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 3.2 lacking in power.
    By Hyperhart in forum Engine & Drivetrain
    Replies: 7
    Last Post: 23rd July 2010, 13:19
  2. 3.2 v6 gsi lacking in power
    By arniuk in forum Engine & Drivetrain
    Replies: 6
    Last Post: 16th July 2010, 07:35
  3. lacking power
    By denzilbud in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 28th June 2009, 21:47
  4. Vectra B engine problem hesitating
    By steve1975l in forum Engine & Drivetrain
    Replies: 1
    Last Post: 14th April 2009, 14:11
  5. engine light on,lacking acceleration,2nd and 5th gear manual mode
    By myvauxhall in forum Vectra C / Signum Troubleshooting
    Replies: 8
    Last Post: 7th April 2009, 10:58

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •