User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: few cdti niggles

  1. #1
    Regular Member
    Join Date
    Sep 2010
    Location
    Milton Keynes
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default few cdti niggles

    A few niggles with my cdti (150) auto that id like some advice on please.

    At low speeds, upto sbout 40mph, the engine feels a little lumpy. Over 40 and it doesnt do it.

    From a standstill, the car is very flat until turbo kicks in. Junctions and roundabouts can be s bit scary if trying to pull awsy we quickly.

    The engine temp reaches 85degrees around town but drops to a bout 78 degrees on the motorway. Is this normal or could thermostat be stuck open?

    Just got the car so not had a chance to do anything to it mechanically yet.

    Chris

  2. #2
    North Wales - Assistant Regional Organiser
    Join Date
    Feb 2010
    Location
    Wirral
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    From that it's a possibility your DPF might be getting a bit clogged (as far as I know all autos and estates had them). Take it for a good run on the motorway. That might clear the slight stutter. Feeling flat is a bit of a characteristic on the engine. Or more specifically the engine map. There's a thread running in the engine and drivetrain section (http://www.vectra-c.com/forum/showth...itation-thread) about this and a remap should fix it. Lastly that'll be the thermostat on the way out. It's not too bad yet though if it's still getting warm.

    Would also recommend a good service, just incase it hasn't been done in a while.

  3. #3
    Regular Member Derek Mc's Avatar
    Join Date
    May 2010
    Location
    Sodding Typical on Sea
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Check your EGR it sounds like it is blocked up as that causes the flat spot I think you are describing, there is a how 2 to remove clean and re-install on here.

  4. #4
    Regular Member
    Join Date
    Sep 2010
    Location
    Milton Keynes
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks guys. How difficult is it to change the thermostat? Anyone tried using an inline stat? Did this on my zt. Thermostat cost a tenner and I positioned it in the top hose. Was in over a year with no problems.

  5. #5
    North Wales - Assistant Regional Organiser
    Join Date
    Feb 2010
    Location
    Wirral
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by chrislloydie View Post
    Thanks guys. How difficult is it to change the thermostat? Anyone tried using an inline stat? Did this on my zt. Thermostat cost a tenner and I positioned it in the top hose. Was in over a year with no problems.
    I suppose you could do. Never thought of it when I did mine, just replaced it with the VX one. It's pretty easy to do if you've got some tools. There's a how2 guide on here too. If you don't have a variety of extension bars (like I didn't) it's easier to remove the battery and the battery box too so you're not cramped. Dead easy.

  6. #6
    Regular Member shinyb1's Avatar
    Join Date
    Jul 2011
    Location
    wigan
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    clean your egr and boost sensor but be light handed with your boost sensor - dont scrub just soak and spray with carb cleaner and split your egr when cleaning that should cure your flat spot , very easy job to do. while your there check your swirl bar is attatched to the 4 swirl pots - if not there is a couple of cheap temp fixes in the how 2 sections .

  7. #7
    Regular Member
    Join Date
    Sep 2010
    Location
    Milton Keynes
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    One less niggle now. Removed the electric mirror switch pack from drivers door and cleaned tge contacts. Result, both mirrors now adjusting perfectky. Before, I had no up or down adjustment.

  8. #8
    Regular Member frasedeb's Avatar
    Join Date
    Mar 2009
    Location
    hull
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    clean EGR, does it give out smoke when pulling away?

  9. #9
    Regular Member Vectra-c-SRI's Avatar
    Join Date
    May 2008
    Location
    Near Glasgow
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

  10. #10
    Regular Member
    Join Date
    Sep 2010
    Location
    Milton Keynes
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    No noticeable smoke when pulling away. Im planning on cleaning the egr. And then having a mas remap and egr and dpf rwmoval.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 6th February 2013, 19:55
  2. Few niggles GSi 3.2 - Help!!!
    By del3.2 in forum Engine & Drivetrain
    Replies: 9
    Last Post: 3rd December 2010, 21:06
  3. more little niggles from the 3.2?
    By jamesr in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 5th February 2008, 14:17
  4. gsi 3.2 niggles
    By Alan in forum Petrol Engine related
    Replies: 13
    Last Post: 21st October 2007, 07:20
  5. A few niggles
    By v6boy in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 17th May 2006, 20:50

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •