User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: new battery in but now starter does not turn all other elecs appear OK bat shows 12.5v

  1. #1
    New Member
    Join Date
    Nov 2009
    Location
    Croydon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default new battery in but now starter does not turn all other elecs appear OK bat shows 12.5v

    Hi
    I hope I am posting in right place now. My car is a 2004 19.cdti vectra My battery was getting gradually worse so replaced it today with a 75ah bosch silver battery. Once all connected up the car started fine I then turned off to tidy things up and had a bit of trouble getting the protective jacket over the battery then when all sorted went to start it again and nothing

    The ignition comes on but when you turn the key there is nothing no attempt for the started to turn although there is a very faint click but not like the starter trying. The battery displays 12.5 volts when I put a meter on and this does not drop when I try and start.the car

    I am wondering if I dislodged something when I was putting the jacket on but can not see anything obvious or if I have blown a fuse somewhere. As far as I can find out although this battery is more powerful than the previous one it should have been OK as 3 retailers recommended it. There is a big fuse on the LHS of the battery compartment but this looks OK

    Does anyone have any ideas what might be wrong or know where the solenoid for the starter is in case I can check this

    Any help would be much appreciated especially as I am not likely to get a garage out easily before Christmas

    Regards

    Dan

  2. #2
    Regular Member Handyandy-UK's Avatar
    Join Date
    Mar 2009
    Location
    Suffolk, Englandshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : SE Touring

    Engine : 3.0

    Year : 2007

    Default

    First route for me would be checking all fuses and for loose/dislodged connections in the area around the battery before trying to start but using a booster pack or a jump to ensure enough juice.... new batteries are 'flash charged' but should be fully charged prior to sale/fitting.

  3. #3
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mk1 renault scenic... I know I know but it drives

    Trim : Basic

    Engine : 1.6 16v

    Year : 2003

    Default

    Check batt connections again

    check all your fuses.

    if it started and now doesn't it'll be something simple

  4. #4
    Regular Member
    Join Date
    Dec 2011
    Location
    Woking
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Exclusive

    Engine : 1.8vvt (Z18XER)

    Year : 2007

    Mileage : 58000

    Default

    Could be you had a bad connection somewhere all along (even before new battery) and have now fully dislodged it. The clicking is the starter relay (solenoid) but sounds like the main fat cable that goes to the starter has a loose connection somewhere.
    How old was you old battery ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 14
    Last Post: 25th December 2012, 17:48
  2. Replies: 6
    Last Post: 23rd December 2012, 21:16
  3. Vectra C battery discharge and OBC shows error in sensor.
    By jyot in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 11th October 2012, 15:16
  4. starter motor ,battery or ignition or anything else
    By tyler boy in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 8th July 2012, 19:24
  5. Replies: 14
    Last Post: 25th August 2006, 00:04

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •