User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Poor Acceleration. 1.9 120bhp

  1. #1
    Regular Member
    Join Date
    Nov 2012
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra 1.9 CDTI 120

    Trim : Energy

    Engine : 1.9 8v 120 BHP

    Year : 2004

    Mileage : 170, 000

    Default Poor Acceleration. 1.9 120bhp

    Hi,

    Im currently having poor acceleration issues Car seems to idle and rev up ok and drives ok'ish locally. However on a long run its very flat. Sometimes i get to 60mph and 2000rpm with my foot flat to the floor and it wont respond anymore.
    Ive got used to driving it in my own way where i gradually build up speed then i can get it to 80mph and overtake ok. Sudden overtaking is out of the question as its got no guts.

    No warning lights showing and ive followed all the 'How 2's regarding EGR, BOOST SENSOR, BOOST CONTROL SOLENOID, replaced vacuum hoses etc etc. Only thing I haven't done is changed the diesel filter on account of not being able to get the sodding lid off.

    What I would like to know is would OBD2 software that you use with a Laptop monitor the performance live and give me a few clues ?

    Many thanks

  2. #2
    Regular Member C-Owner's Avatar
    Join Date
    May 2011
    Location
    South London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by carling View Post
    Hi,

    Im currently having poor acceleration issues Car seems to idle and rev up ok and drives ok'ish locally. However on a long run its very flat. Sometimes i get to 60mph and 2000rpm with my foot flat to the floor and it wont respond anymore.
    Ive got used to driving it in my own way where i gradually build up speed then i can get it to 80mph and overtake ok. Sudden overtaking is out of the question as its got no guts.

    No warning lights showing and ive followed all the 'How 2's regarding EGR, BOOST SENSOR, BOOST CONTROL SOLENOID, replaced vacuum hoses etc etc. Only thing I haven't done is changed the diesel filter on account of not being able to get the sodding lid off.

    What I would like to know is would OBD2 software that you use with a Laptop monitor the performance live and give me a few clues ?

    Many thanks
    Sounds like a Maf sensor fault

    As far as the diesel filter goes......

    Remove the housing from the car, place in a bench vice and use a oil filter removal tool to undo the cap on the filter housing.

    Put new filter and seals in and tighten up in the vice - refit to car.
    Last edited by C-Owner; 22nd December 2012 at 17:48.

  3. #3
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    Fuel filter and air filter maybe?

  4. #4
    Regular Member
    Join Date
    Nov 2012
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra 1.9 CDTI 120

    Trim : Energy

    Engine : 1.9 8v 120 BHP

    Year : 2004

    Mileage : 170, 000

    Default

    Maf sensor ?. Where is that located. Not thought to check the air filter, the car had been run into the ground and came with no history would a dirty air filter effect running ?.

    Thanks

  5. #5
    Regular Member C-Owner's Avatar
    Join Date
    May 2011
    Location
    South London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by carling View Post
    Maf sensor ?. Where is that located. Not thought to check the air filter, the car had been run into the ground and came with no history would a dirty air filter effect running ?.

    Thanks
    In that case clean the Maf & Map sensors

    Google or search this forum how to clean them, there's hundreds of threads on the subject.

    Any filter that's past its serviceability will contribute to poor running.,


  6. #6
    Regular Member
    Join Date
    Nov 2012
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra 1.9 CDTI 120

    Trim : Energy

    Engine : 1.9 8v 120 BHP

    Year : 2004

    Mileage : 170, 000

    Default

    Cheers Guys. Ive overlooked the serviceable items so will sort those first then see how it goes.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Signum 2.2 Direct - misfire?/vibration/poor acceleration
    By Fenris in forum Engine & Drivetrain
    Replies: 15
    Last Post: 31st July 2011, 23:32
  2. My poor poor veccy :(
    By tammyman09 in forum Vectra C / Signum Car Chat
    Replies: 17
    Last Post: 9th June 2011, 10:46
  3. No/poor Acceleration under 2.5k revs
    By Diesel Dan in forum Engine & Drivetrain
    Replies: 25
    Last Post: 16th December 2010, 23:44
  4. Nooooooo!!!!, my poor, poor car!!
    By Duncan in forum Vectra C / Signum Car Chat
    Replies: 208
    Last Post: 11th May 2006, 16:32
  5. My Poor Poor Signum
    By Brake buster in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 30th September 2005, 15:45

Visitors found this page by searching for:

vectra sluggish acceleration

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •