User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: CD70 Problem!!

  1. #1
    Regular Member
    Join Date
    Dec 2012
    Location
    Benfleet
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9CDTi 150

    Year : 2005

    Default CD70 Problem!!

    Driving home from work today and my CD70 navi went screwy on me!! It spat out the map disk and now I can't turn the stereo off!! Can't select the Nav option from the main screen, BC and stereo work ok accept the stereo doesn't go off when the ignition is switched off, and can't be turned off with the power switch. Also can't insert the Nav disk, it goes in and sounds like its loading, but the disk isn't pulled in to load!

    i've had to pull the fuse now.

    help?????

  2. #2
    Regular Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXR8 6.0 muscle SRI ESTATE XP1

    Trim : VXR/ SRI ESTATE CDTI XP1

    Engine : 6.0 V8 Thunder

    Year : 2008

    Default

    have you tried pulling the battery lead off and leaving it off for half hour and resetting the system?

  3. #3
    Regular Member
    Join Date
    Dec 2012
    Location
    Benfleet
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9CDTi 150

    Year : 2005

    Default

    Haven't tried that, but it's as if something has come adrift internally! When trying to insert a disk there is resistance ( as usual) but when you expect the disk to be pulled into the drive it makes a noise as if it were loading but doesn't pull the disk in!
    I'll try to disconnect the battery tomorrow after work.

  4. #4
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    Quote Originally Posted by chrisvectra View Post
    have you tried pulling the battery lead off and leaving it off for half hour and resetting the system?
    This is usually the FIRST thing I would do with any Full CAN system.
    You are okay, the CD70 IS a full CAN radio.

    Half CAN units should only do this IF you have the audio pass code.

    It does sound like the head-unit has thrown a wobbler - pulling the battery should sort it for you.

    If not, then it is a relatively simple job to pull the CD70 to bits... but you will need a set of Torx keys to undo the screws.
    I have 3 CD70's and none of them have suffered mechanical failure... usually just dirty laser lenses.

  5. #5
    Regular Member
    Join Date
    Dec 2012
    Location
    Benfleet
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9CDTi 150

    Year : 2005

    Default

    Took it out of the car all day yesterday while at work. When i put it back there was no difference, comes straight on as soon as you turn the ignition on, nothing on the Nav tab but stereo works. when you turn the ignition off the stereo remains on. pressing the power button on the front of the stereo makes no difference it just won't turn off. i then have to pull it out and dissconnect it.

    Had a quick look at it when i got home and as you say not too dificult to dismantle, but not sure what i'm looking for once i got it open!! no obvious signs of anything missing or loose, but surely a dirty lens would just fail to read the disc, its as if this one physically can't load it!

  6. #6
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    In which case, you need to look at the lower drive, and see if anything looks mis-placed or there is anything stuck in the mechanism or broken.

    Worst comes to the worst, I have a spare CD70 here for spares and repairs... the Nav CD drive works fine.
    But it is still paired to a previous vehicle. I bought it to modify the facia, so that it would fit my Cavalier - long story, lol.

  7. #7
    Regular Member
    Join Date
    Dec 2012
    Location
    Benfleet
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9CDTi 150

    Year : 2005

    Default

    sorry, been a while, but other things came up which took priority!!

    Do you have the spare nav drive, if so how many beer tokens would it take for me to persuade you to part with it??

    would it need to be un-pair if i just swapped out the nav drive into my current CD70??

  8. #8
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    Ah... Sorry my friend,
    I litterally sold it last week.
    Just keep an eye on ebay... They do pop up as for spares or repairs quite often.
    That's how I bought mine.

  9. #9
    Regular Member
    Join Date
    Dec 2012
    Location
    Benfleet
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9CDTi 150

    Year : 2005

    Default

    thanks anyway!!

  10. #10
    Regular Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXR8 6.0 muscle SRI ESTATE XP1

    Trim : VXR/ SRI ESTATE CDTI XP1

    Engine : 6.0 V8 Thunder

    Year : 2008

    Default

    You should still the battery lead fella and do a reset and see if that clears it. I had a similar fault and pulling the battery lead cured it

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. CD70 Nav problem. Help apreciated
    By willi32 in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 17th July 2012, 05:17
  2. problem with the cd70
    By toughmat in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 14th August 2011, 13:16
  3. CD70 problem please help!
    By TopRod in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 20th November 2010, 19:38
  4. CD70 MP3 Problem
    By BGV in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 22nd June 2007, 21:33
  5. Sat Nav CD70 CD Problem
    By SteveBray in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 24th May 2007, 09:12

Visitors found this page by searching for:

cd70 cant insert navi cd disc

my cd 70 has some engine problem

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •