User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: HELP! Automatic gearbox problems

  1. #1
    New Member
    Join Date
    Jan 2007
    Location
    Portugal
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default HELP! Automatic gearbox problems

    Hello

    Iím owner of a OPEL VECTRA C 2.0 Dti, 5 gears automatic gearbox, Iíve purchased it 2 years ago and until now I had no troubles. One month ago the car had the following problem, it signaled a fault on the desktop (tool symbol) and the gearbox in automatic mode blocked on the fifth gear. In order to drive Iíve changed into sequential mode but the gears available were only the second and the fifth, all the others were not possible to be selected. Iíve went to the OPEL official workshop it stayed there for one week and their diagnosis was a faulty gearbox ECU, the repair cost me 1200 Euros, ok by me if it had solved the problem. Two weeks later Iíve got the same problem in the of traffic jam it was quite annoying to drive with only two gears available. I went back to the same official OPEL workshop and the car stayed there for 2 weeks ( :-( AGAIN ) and they told me that the problem was on the gearbox itself, the price for the new gearbox is 5100 Euros times 21% taxes, plus the handwork. It is quite a punch in my wallet.

    My questions are:

    Is there anybody out there with the same problem?

    If so how did you solved the problem?

    Can the problem be from another source besides the gearbox (electronics)?

    Do you think the guys in the workshop are incompetents and canít find the truth source of the problem?

    Iíve read this ďOn the 1.9 diesels, the wiring harness can rub bare on the transmission casing causing a short circuit that blows the main fuse leaving the car completely disabled. There may be a recall or at least a tsb to check for this.Ē on

    <http://www.honestjohn.co.uk/carbycar/index.htm?p_make=VAU&h_make=VAU&p_model=%20526 > can this be the source of the problem and the stupid mechanics wont find it?

    HELP!!!

  2. #2
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just a couple of ideas..

    either the clutch bands have worn out or

    the gear selector switch has worn on it's contacts (it's on the top of the gearbox) or

    the valve pack within the gearbox has a fault.

    and do you have any funny colour coolant in the engine.. our old vectra had a leak between the radiator and the gearbox that meant we had to have a new gearbox.. all the engine coolant got into the gearbox.

  3. #3
    New Member
    Join Date
    Jan 2007
    Location
    Portugal
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Gsi3.2 View Post
    Just a couple of ideas..

    either the clutch bands have worn out or

    the gear selector switch has worn on it's contacts (it's on the top of the gearbox) or

    the valve pack within the gearbox has a fault.

    and do you have any funny colour coolant in the engine.. our old vectra had a leak between the radiator and the gearbox that meant we had to have a new gearbox.. all the engine coolant got into the gearbox.

    Well the mechanic said something about the gearbox valves, he said he reprogrammed the valves timing to see problem was solved by this way, but seems like it didnít and he said the solution was a new gearbox, which for me is quite expensive (plus the new gearbox ECU from the first repair).

  4. #4
    On a Sabbatical VauxVeteran's Avatar
    Join Date
    Mar 2006
    Location
    Nicking Ya Dinner.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Breakers yard, then get shot of it.

  5. #5
    New Member
    Join Date
    May 2007
    Location
    Ilford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi - I have got EXACTLY the same problem.

  6. #6
    Regular Member Sundance's Avatar
    Join Date
    Jan 2007
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    There have been problems with moisture in the input and output speed sensors connections, i had one that would lose all gears except 2 and 5, also had codes for both sensors, removed and cleaned both sensors, refitted and all was ok for a couple of weeks then the fault returned. tech 2 showed a fault with the speed output sensor. Renewed it and its been fine since.
    This was on the AF23/33 gearbox.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Automatic gearbox, recommended?
    By astradriver in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 11th February 2013, 19:09
  2. Vectra C 1.9 CDTI Automatic Problems - Engine & Gearbox
    By johal87 in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 13th July 2012, 23:37
  3. Automatic Gearbox
    By delboy2028 in forum Engine & Drivetrain
    Replies: 9
    Last Post: 1st March 2011, 16:28
  4. Signum 2.2 dti automatic gearbox
    By apacheenzo in forum Engine & Drivetrain
    Replies: 0
    Last Post: 2nd April 2010, 21:06
  5. Automatic Gearbox problem
    By tomhrb in forum Troubleshooting
    Replies: 8
    Last Post: 4th June 2009, 16:54

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •