User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: 2004 vectra 1.9 cdti 120bhp...Flat spots and sluggish pulling off.

  1. #1
    Regular Member
    Join Date
    Nov 2012
    Location
    Derby
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default 2004 vectra 1.9 cdti 120bhp...Flat spots and sluggish pulling off.

    Hi there, first post so please bear with me. Having read the forum for the last few days I cant seem to sort the problem.

    I bought the car a month ago and having only test driven it locally it seemed to drive ok, however on a longer run i keep coming up against flat spots around 2200 rpm !! I can get it to around 70mph but it just flats out at that, pedal to the floor and rpm going no higher than 2200. Then all of a sudden it'll be ok for a few miles.

    After driving a mates car (exactly the same car) I can tell right away its sluggish pulling away in 2nd and 3rd. The car is quite high mileage 175,000. It idles ok and revs up ok and for general local driving it seems ok.

    After reading the forum I have tried the following....

    Cleaned out the EGR valve.... No difference even tried it with electrical connector unplugged.

    Cleaned out the Boost sensor which was seriously gummed up.... No diffference

    Checked the vacuum hoses best i could, some perishing but no leaks.

    The boost control valve had a broken plastic (in) pipe where you connect the vacuum hose and it had been bodged up so I bought a second hand valve off flebay for £25. Fitted it correctly but still no difference...

    Could it be anything else ?? sorry for the long post.

  2. #2
    Regular Member MrDerv's Avatar
    Join Date
    Nov 2011
    Location
    North East (Beamish)
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sounds like it could be a sticky VNT mechanism on the turbo.

    Although, this could possibly help.. http://www.vectra-c.com/forum/showth...-1500-2000-rpm

  3. #3
    Regular Member
    Join Date
    Nov 2012
    Location
    Derby
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by MrDerv View Post
    Sounds like it could be a sticky VNT mechanism on the turbo.

    Although, this could possibly help.. http://www.vectra-c.com/forum/showth...-1500-2000-rpm
    Thanks for the reply. Would I have to have the turbo off to get at that ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yes i know another thread about egr and flat spots
    By Sistill in forum Engine & Drivetrain
    Replies: 5
    Last Post: 18th August 2012, 13:44
  2. problems with vectra 2004 diesel 120bhp
    By DavyB in forum Troubleshooting
    Replies: 12
    Last Post: 29th February 2012, 11:03
  3. New Vectra 120bhp CDTi engine!!!!
    By Maverick in forum Vectra C / Signum Car Chat
    Replies: 38
    Last Post: 22nd May 2007, 18:30

Visitors found this page by searching for:

vectra cdti valve 8v boost control valve

vectra c 1.9 cdti flat spot high revs

vectra 1.9 flat spot at 2000

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •