User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: spanner light on

  1. #1
    Regular Member neil52's Avatar
    Join Date
    Oct 2012
    Location
    leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default spanner light on

    ive just changed fuel filter soaked the new filter first in fuel took it for a drive all was ok for 10 mins or so then the spanner warning light came on the temp gauge went up so slowed down and engine was very erratic, any ideas could i have knocked something
    Last edited by neil52; 8th December 2012 at 15:50.

  2. #2
    Regular Member neil52's Avatar
    Join Date
    Oct 2012
    Location
    leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ive just tried it again but the temp gauge is shooting up and now as well as the spanner light the battery light is on please any ideas it was running ok before i changed fuel filter.
    Last edited by neil52; 8th December 2012 at 17:22.

  3. #3
    Regular Member
    Join Date
    Feb 2009
    Location
    crook
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    check all connection near filter,incase you have knocked them
    how far your temp gauge shooting up to ?

  4. #4
    Regular Member neil52's Avatar
    Join Date
    Oct 2012
    Location
    leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    it gets to 80 after just starting up then keeps on going up darent leave it running too long

  5. #5
    Regular Member SlowCoach's Avatar
    Join Date
    Jan 2012
    Location
    Houghton Le Spring
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI 150

    Trim : Smart and Bad!

    Engine : Z19DTH

    Year : 2008

    Mileage : 105000

    Default

    Test ur thermostat and check rad fan functions ok.

  6. #6
    Regular Member neil52's Avatar
    Join Date
    Oct 2012
    Location
    leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    it was all working fine till i changed fuel filter, i will wait till tomorow when its light and do checks

  7. #7
    Regular Member
    Join Date
    Feb 2009
    Location
    crook
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Is fan belt still on ?

  8. #8
    Regular Member neil52's Avatar
    Join Date
    Oct 2012
    Location
    leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    tried the car this morning turns over great but wont start, i wish id never replaced fuel filter now. think i will call the RAC just realised ive got home start.

  9. #9
    Regular Member
    Join Date
    Feb 2009
    Location
    crook
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like air locked fuel filter.

  10. #10
    Regular Member Signum-Steve's Avatar
    Join Date
    Feb 2009
    Location
    Cramlington Northumberland, V6 Jaguar S-type Sport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar S-Type V6

    Trim : Sport

    Engine : Petrol

    Year : 2003

    Default

    You need to crack off the four fuel pipes which feed your pots mate. Turn your engine over until you see diesel coming out of them then nip them up tight one by one. Only crank for a short while no longer than 20-30 seconds so you dont hurt your starter motor!
    I think you need a 15 mm spanner to do this? Once nipped back up crank the engine again and your car will start. job done

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Problems with Air bag light, ABS, Anti Skid & Spanner light
    By WeDesign in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 4th December 2012, 21:23
  3. Should I Have A Spanner Light aswell as an Engine Light on My Signum?
    By StreetDragster in forum Engine & Drivetrain
    Replies: 16
    Last Post: 18th August 2012, 11:57
  4. EGR Valve, Engine Management Light & Spanner Light
    By guygreen in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th December 2010, 20:09
  5. spanner light then engine management light
    By learoy69 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 12th March 2010, 20:10

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •