User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: water pump

  1. #1
    Regular Member
    Join Date
    Aug 2011
    Location
    Bristol
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default water pump

    What happens if the water pump fails??
    Changed most internals for the engine and I have oil in the header.
    No water in the engine mixing as oil is still fine.
    Coolant leaking from engine but still not found from where.
    If the head gasket goes would that mean you will be getting water into the engine?
    I know it's the most difficult job due to the position but how much will it cost on changing the water pump (I have the pump and gasket)?
    Mechanic has looked and can't find the leak.
    Could this be a cracked head instead?

  2. #2
    Regular Member
    Join Date
    Aug 2011
    Location
    Bristol
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Also, 2.2 direct Z22YH.
    The Temp seems to be fine when driving and only went above 90 once the other day and dropped quickly down to 80 then slowly back to 90.
    No smoke (apart from the obvious), car has just passed emissions test.

  3. #3
    Regular Member Ben50n's Avatar
    Join Date
    Dec 2011
    Location
    Seaham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Are you getting mayonaise in the rocker cover?

    Does your car have an oil cooler that is attached to the radiator?

  4. #4
    Full Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by GCusdin View Post
    What happens if the water pump fails??
    Changed most internals for the engine and I have oil in the header.
    No water in the engine mixing as oil is still fine.
    Coolant leaking from engine but still not found from where.
    If the head gasket goes would that mean you will be getting water into the engine?
    I know it's the most difficult job due to the position but how much will it cost on changing the water pump (I have the pump and gasket)?
    Mechanic has looked and can't find the leak.
    Could this be a cracked head instead?
    If the water pump actually fails your in trouble. No water/coolant being pumped around the engine will mean it will just cook itself and ruin the engine.

    So you do not actaully have water in your oil? I assume the water/coolant is your header tank has not turned a greyish colour and got itself a sludgey coating inside it? have you had a head gasket test done as well, i thought your mechanic would havbe checked for that anyway. Is your water rad is good order?
    My old Signum, the animal; she now rests in pieces in several other members cars.. https://www.vectra-c.com/forum/garag...vehicle&id=200
    The wifes vec show car, started as a standard daily driver and ended up like this. https://www.vectra-c.com/forum/garag...vehicle&id=709



  5. #5
    Regular Member
    Join Date
    Aug 2011
    Location
    Bristol
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Nothing in the rocker cover. Still looked fine.
    No oil cooler.
    The head gasket was new 4 weeks ago and oil started coming in about a week ago.
    Radiator was replaced last year due to leaks.
    He did a pressure test on the coolant system.
    He has a loads to do and I don't want to keep giving him more before I get the car back tonight. He is currently changing the steering rack and needs to get it back to pass MOT today. At the same time I don't want him doing to many tests I have to pay for as he did not do the engine. Also I aint that minted.
    Due to the coolant leak I reckon it could be head gasket but he says 60% water pump and 40% head gasket.
    Seems strange how I have no coolant in the engine.
    He is due to change oil today so will keep my eye on it.

  6. #6
    Regular Member Ben50n's Avatar
    Join Date
    Dec 2011
    Location
    Seaham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Why was the head gasket changed? Did they skim the head and test for cracks?

    Possibly still the head gasket.

  7. #7
    Regular Member
    Join Date
    Aug 2011
    Location
    Bristol
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    They should have tested the head and skimmed it.
    I did pay for that to be done.
    Gasket was changed as timing chains, valves and piston rings were being done

  8. #8
    Regular Member nutron's Avatar
    Join Date
    Jul 2005
    Location
    South Central England
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)

    Default

    If the problem appeared after the head gasket was changed it is the prime candidate as the water pump has no interaction with the oil system. The only place water and oil could mix is in the block/head unless you have a water cooled turbo (which you don't). I'd slap the guy about a bit and find out if the head was sent away for skimming and pressure testing.

  9. #9
    Regular Member
    Join Date
    Aug 2011
    Location
    Bristol
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    He said he thinks the leak is coming from somewhere around the area of the water pump or around the cover.
    Could this be a possible water pump gasket failing due to being stood with probably no liquid whilst the engine was being done?
    I need to have a look tomorrow for some hints.
    Still doesn't explain the oil in header tank does it?

  10. #10
    Regular Member
    Join Date
    Jul 2009
    Location
    Littleborough
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I've had the same problem. It first occurred 18 months after cam chain problem where the head and valves were removed skimmed etc. Fisrt sign was oil in water then water in oil, a right mess. head taken off skimmed, pressure tested. One worried garage as they couldn't find a fault. Three months later its started again. Flush and flog me thinks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Water pump.
    By Kenny_Exclusiv in forum Engine & Drivetrain
    Replies: 5
    Last Post: 24th September 2012, 22:19
  2. New water pump due???
    By R33Leroy in forum Engine & Drivetrain
    Replies: 6
    Last Post: 1st April 2012, 21:27
  3. Water pump?
    By Tigger in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 27th August 2010, 23:00
  4. Water pump
    By FRANKA in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 31st March 2010, 18:55
  5. Water Pump 2.2
    By richpu in forum Engine & Drivetrain
    Replies: 3
    Last Post: 27th January 2009, 01:46

Visitors found this page by searching for:

z18xe water pump keeps on leaking

vectra z20net water pump diy site:www.vectra-c.com

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •