User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Vectras dead

  1. #1
    Regular Member tiimi's Avatar
    Join Date
    Sep 2012
    Location
    anglesey, uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectras dead

    went to my car after work tonight, turned the key and.......nothing. a work mate gave me a jump start, but then as he took the leads off, car died again. he gave me a second jump and this time i gave plenty of revs, the all lights started flashing on the dash, the revometer stuck in the middle, and even with revs on half way, car just died. after a little bit of research, i have self diagnosed it to be the alternator due to car not holding charge after being jump started. can anybody confirm this for me ?? i have had to leave the car at work and hopefully get it done tommorow !?

  2. #2
    Regular Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Here
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    33 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Default

    Sounds like the Alternator is goosed and taken the battery with it bud. The cold weather can really kill a battery.

  3. #3
    Regular Member tiimi's Avatar
    Join Date
    Sep 2012
    Location
    anglesey, uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    so you reckon ill need new battery aswell

  4. #4
    VIP-Member antowens's Avatar
    Join Date
    Dec 2011
    Location
    liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    if its on a 1.9 i had a mate who had a similar problem and it turned out it was a black box on the back of the alternator not the alternator its self

  5. #5
    Regular Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Here
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    33 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Default

    Well get it running and put a multi meter over the terminals first, check it is the alternator first. If it is and you replace it and it still dont hold a charge then yes. You could try halfords or kwik fit, they will have testers for testing the battery, but then you run the risk of them telling you its knackered just to get the sale.

  6. #6
    Regular Member tiimi's Avatar
    Join Date
    Sep 2012
    Location
    anglesey, uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    im js gnna stick an alternator on it i think and go from there !

  7. #7
    Regular Member Exclusive BV's Avatar
    Join Date
    Apr 2010
    Location
    West Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i have heard about this happening on vecs, sometimes can be random lights flashing on the dash. the black bit on the alternator is the regulator unit. on some units i think it can be refurbished. you may be able to pick up a refurb unit cheap. but test the output from it first

    how old is the battery? might be ok after a charge

    good luck mate

  8. #8
    Regular Member tiimi's Avatar
    Join Date
    Sep 2012
    Location
    anglesey, uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    dont know how old battery is but looks like new. i think to be fair its definitive to say its the alternator, after jump start successful, but then died after cables being removed, twice !! any way, had a quote for a second hand unit, 3 month warrantee, £74 inc. vat and delivery.

  9. #9
    Regular Member tiimi's Avatar
    Join Date
    Sep 2012
    Location
    anglesey, uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    and partners cousin husband will fit it for £50

  10. #10
    Regular Member tiimi's Avatar
    Join Date
    Sep 2012
    Location
    anglesey, uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ok, does anybody know if the unit is a denso or bosch ?? the guy on the phone said if its one or the other, ill need a plug aswell ?? i got 1.9 cdti 8v full canbus

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. how many vectras
    By patch22 in forum Vectra C / Signum Car Chat
    Replies: 17
    Last Post: 15th September 2011, 08:17
  2. Most of my Vectras!
    By Mart2823 in forum Quick Photo Album
    Replies: 5
    Last Post: 20th March 2011, 20:40
  3. New to vectras
    By Cheese_Roll in forum Quick Photo Album
    Replies: 5
    Last Post: 21st July 2010, 17:11
  4. new to vectras
    By john-d in forum Introduce yourself.
    Replies: 23
    Last Post: 11th December 2009, 22:01
  5. Vectras Gone!!!
    By markone in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 14th January 2009, 22:09

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •