User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Major heater blower problems!!!!!

  1. #1
    Regular Member
    Join Date
    Oct 2012
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Major heater blower problems!!!!!

    PLEASE HELP GUYS!!

    hi guys am having major problems with my heater blower ,it was only working on 4 till a couple of days ago when we had heavy rain when it just stopped working completely

    i thought just change the resistor job Done but no nothing happens at all when i turn it on after ive changed it ..what else could it be?

    ive tried to take the motor out but i cant figure it out

    any suggestion please guys .......ITS FREZZING
    Last edited by Carper31; 3rd December 2012 at 19:52.

  2. #2
    Regular Member beat275's Avatar
    Join Date
    Aug 2011
    Location
    Newcastle West Denton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Hatch

    Trim : SRI

    Engine : 2.0T

    Year : 2003

    Mileage : 90000

    Default

    another heater problem lol. change the relay for speeds 1 2 and 3 think there mite be a separate one for the 4th

  3. #3
    Regular Member
    Join Date
    Oct 2012
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    the blower is not working at all now

  4. #4
    Regular Member beat275's Avatar
    Join Date
    Aug 2011
    Location
    Newcastle West Denton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Hatch

    Trim : SRI

    Engine : 2.0T

    Year : 2003

    Mileage : 90000

    Default

    have you tested it? try the relays first. there CHEAP like the budgie

  5. #5
    Regular Member
    Join Date
    Oct 2012
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    wheres the relays located? i havent tested it icant get the motor out ,ive taken all the screws out but its not budging and i dont wanna break it

    any help in taking it out and locating relays would be a great help

  6. #6
    Regular Member beat275's Avatar
    Join Date
    Aug 2011
    Location
    Newcastle West Denton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Hatch

    Trim : SRI

    Engine : 2.0T

    Year : 2003

    Mileage : 90000

    Default

    take the glove box out and on the left hand side you should see a few relays. theres a blue one for the 1 2 3 but dont know which one is for the 4th

  7. #7
    Regular Member
    Join Date
    Oct 2012
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    now am confussed are you saying if i replace the relays it should work ??

  8. #8
    VIP-Member Damo77's Avatar
    Join Date
    May 2010
    Location
    Petersfield, Hampshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 1.9 CDTi 8v

    Year : 55

    Mileage : 92,000

    Default

    Not sure if you've come across this thread Carper but there are a few pics which may help with removing the blower:-

    http://www.vectra-c.com/forum/showth...ter-Blower-Fan

    Best of luck

    Damo
    Already replaced:-
    Alternator,
    Drilled/Grooved Discs & Pads, Eibach Springs, EGR Valve, 50W HID's 6000k, K&N Panel Filter, LED footwell & boot lights

  9. #9
    Regular Member beat275's Avatar
    Join Date
    Aug 2011
    Location
    Newcastle West Denton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Hatch

    Trim : SRI

    Engine : 2.0T

    Year : 2003

    Mileage : 90000

    Default

    yeah mate should work

  10. #10
    VIP-Member Damo77's Avatar
    Join Date
    May 2010
    Location
    Petersfield, Hampshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 1.9 CDTi 8v

    Year : 55

    Mileage : 92,000

    Default

    Just done a quick search and come across some info regarding the relay as well as another issue someone else had which was down to the heater controls themselves

    Just a few more leads for you to look into mate really, hope it helps

    BLOWER RELAY Info

    HEATER CONTROLS Info
    Already replaced:-
    Alternator,
    Drilled/Grooved Discs & Pads, Eibach Springs, EGR Valve, 50W HID's 6000k, K&N Panel Filter, LED footwell & boot lights

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. heater blower problems
    By jondaw in forum Vectra C / Signum Troubleshooting
    Replies: 4
    Last Post: 22nd August 2012, 08:58
  2. heater blower not doing its job
    By coylo5 in forum Electrical & ICE (including SatNav)
    Replies: 10
    Last Post: 22nd February 2012, 14:58
  3. Heater / Blower Fan
    By chris2464 in forum Bodywork & Interior
    Replies: 3
    Last Post: 5th January 2012, 13:30
  4. Heater blower!!!!!
    By mitch in forum Electrical & ICE (including SatNav)
    Replies: 14
    Last Post: 19th November 2010, 00:15
  5. Heater blower resistor problems
    By wildtrout in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 4th July 2010, 16:20

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •