User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: clicking top mounts

  1. #1
    Regular Member
    Join Date
    Aug 2012
    Location
    Stockton-on-Tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default clicking top mounts

    Ever since i fitted FK coilover suspension iv had a clicking noise from the right hand top mount when i turn left or right and sometimes when going over rough bumps

    Iv now taken off the FK and using the standard with APex -35mm lowering springs 10x better as far as noises from the back are concerned but iv still got the clicking but now i have it from both top mounts (more right hand side)

    Is it possible that they just need tightening up a bit more?

    or does this mean new top mount bearings?

    cheers Craig

  2. #2
    Regular Member
    Join Date
    Sep 2007
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    shoulda put new top bearings on when you had it stripped .

  3. #3
    Regular Member
    Join Date
    Aug 2012
    Location
    Stockton-on-Tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by gsxrster View Post
    shoulda put new top bearings on when you had it stripped .
    i would like to be sure that is what the problem is....iv got the new top bearing in my room thats the most frustrating part but when i checked it when it was off the car it seemed completely fine.. No grinding... Smooth. so i couldnt see the point in replacing it.. O well i guess ill have to take it all apart again!

  4. #4
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    56 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mk1 renault scenic... I know I know but it drives

    Trim : Basic

    Engine : 1.6 16v

    Year : 2003

    Default

    Get someone to turn steering whilst you watch the top mounts will see the notchyness in them

    but tbh of you have new ones may aswel fit them anyway

  5. #5
    Regular Member
    Join Date
    Jul 2011
    Location
    gloucestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : 2.0 turbo

    Year : 2007

    Mileage : 103000

    Default

    Sorry to jump in on this thread but I have the same problem since I have changed to bilstein shocks. Get clicking everytime I turn right or left. When you changed the top mounts did the problem go?
    Thanks mike

  6. #6
    Regular Member
    Join Date
    Aug 2012
    Location
    Stockton-on-Tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by mikey2704 View Post
    Sorry to jump in on this thread but I have the same problem since I have changed to bilstein shocks. Get clicking everytime I turn right or left. When you changed the top mounts did the problem go?
    Thanks mike
    Im yet to change them.. hope to do it this week.. iv got the tools ready shouldnt take to long but at the moment it sounds terrible.. sounds like the shock is loose as hell. Checked it all though and its tight so must be the bearings completely shot.

    I think its got something to do with its always under compression while in the car and wears into its own groves over time..Once you take them off and disturb them the bearings are allowed to move into a new position and thats when the noise starts. Right hand side only clicks when i turn the left hand side makes noises as soon as i hit a bump or a bit of un even road.

  7. #7
    Regular Member
    Join Date
    Jul 2011
    Location
    gloucestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : 2.0 turbo

    Year : 2007

    Mileage : 103000

    Default

    Mines only on the drivers side I'm going to strip it all down later in the week to see if its anything simple like the spring not sat correct if not I'm going to have to order some top mount bearings. Where did you get yours from? Vauxhall?

  8. #8
    Regular Member
    Join Date
    Aug 2012
    Location
    Stockton-on-Tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ordered mine off euro car parts using their deal discount code. But you can easily order tthem off eBay for £20 each. Not sure how much the dealer charges. Let me know how it goes. Mines driving me insane. Hope it is as easy as replacing the top mount bearings.

  9. #9
    Regular Member
    Join Date
    Aug 2012
    Location
    Stockton-on-Tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Any news on changing top mounts?

  10. #10
    Regular Member
    Join Date
    Jul 2011
    Location
    gloucestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : 2.0 turbo

    Year : 2007

    Mileage : 103000

    Default

    I'm doing my top mounts and strut plate 2moro morning with a mate. It wasn't something simple like I was hoping never mind it will all be sorted by 2moro afternoon. Happy times.

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. rad mounts
    By chris1804 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 30th January 2013, 16:31
  2. rad mounts help
    By n8sby in forum Suspension, Wheels & Brakes
    Replies: 1
    Last Post: 16th March 2011, 10:21
  3. Top mounts??
    By LEW1S2006 in forum Suspension, Wheels & Brakes
    Replies: 1
    Last Post: 9th December 2009, 17:51
  4. rad mounts
    By decks in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 10th February 2009, 22:50
  5. rad mounts
    By decks in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 11th December 2008, 13:42

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •