User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: Front Wiper linkage problem

  1. #1
    Regular Member
    Join Date
    Aug 2012
    Location
    Stockton-on-Tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Front Wiper linkage problem

    Passenger side wiper linkage has decided to brake.

    I seen the linkage arm just sitting on the top of the body work and not connected so i know its that.

    What is it that tends to wear is it the ball joint or is it the arm with the cup socket?

    you can buy new arms with new sockets but im wondering if the ball has also worn away to nothing as well cant really feel it that well to tell..

    and last can you replace the ball joint or do you need whole new linkage?

    cheers

  2. #2
    Regular Member Chunklamb's Avatar
    Join Date
    Jan 2012
    Location
    Milton keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 330D (13) Tourer 258 Auto & Signum 1.9 CDTI (07) 150 Auto

    Trim : M Sport and Design

    Engine : Z19DTH

    Year : 2007

    Mileage : 38100

    Default

    http://www.vectra-c.com/forum/showth...-wiper-linkage

    You could always just use a load of cable ties to hold it in place until you can get it fixed or replaced. Like here -

    http://www.vectra-c.com/forum/showth...=wiper+linkage

    Theres a few kits on the Ebay.

  3. #3
    Regular Member
    Join Date
    Aug 2012
    Location
    Stockton-on-Tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Chunklamb View Post
    http://www.vectra-c.com/forum/showth...-wiper-linkage

    You could always just use a load of cable ties to hold it in place until you can get it fixed or replaced. Like here -

    http://www.vectra-c.com/forum/showth...=wiper+linkage

    Theres a few kits on the Ebay.
    yeh i had a look at that im going to be doing that for my long 4 hour drive home hopefully it works.. iv had a look at the new arms on ebay which is all well and good if the balls dont normally rust away as well?

  4. #4
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : ls

    Engine : 1800

    Year : 04

    Mileage : 134000

    Default

    Quote Originally Posted by craig20102010 View Post
    Passenger side wiper linkage has decided to brake.

    I seen the linkage arm just sitting on the top of the body work and not connected so i know its that.

    What is it that tends to wear is it the ball joint or is it the arm with the cup socket?

    you can buy new arms with new sockets but im wondering if the ball has also worn away to nothing as well cant really feel it that well to tell..

    and last can you replace the ball joint or do you need whole new linkage?

    cheers
    its a common fault on the vectra c the ball joint breaks

    mine did the same it cost 90 pounds from vauxhall for the wiper linkage
    http://www.ebay.co.uk/itm/VAUXHALL-V...item43b61848a7

    http://www.ebay.co.uk/itm/Genuine-Va...item4aba7f8aff

  5. #5
    Regular Member
    Join Date
    Sep 2010
    Location
    north east uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by craig20102010 View Post
    yeh i had a look at that im going to be doing that for my long 4 hour drive home hopefully it works.. iv had a look at the new arms on ebay which is all well and good if the balls dont normally rust away as well?
    Usually its the cup on the arm that wear out m8. I fitted a linkage set from Ebay around 2 years ago, cost around £29-ish & still going strong.
    Also, my balls were a little rusty too but the new arm cups were a really good tight fit.

  6. #6
    Regular Member
    Join Date
    Aug 2012
    Location
    Stockton-on-Tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    well i was tempted to just buy the arms at £30 but i cant be sure if they have completely worn yet.. weathers been terrible lately so havnt had chance to take it all apart to look. It seems to sort of clip back on at the minute but falls off, so maybe it is just the cup thats worn out.

  7. #7
    Regular Member kentish_bloke's Avatar
    Join Date
    Mar 2008
    Location
    Sittingbourne, Kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : Elite

    Engine : 1.8 VVT

    Year : 2009

    Mileage : 42800

    Default

    I've had the same trouble. Used the how2 to carry out the cable tie fix & it's been going for at least 2 years now. No intention of paying silly money to replace the whole thing when i can get the cable ties for free!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Front wiper linkage/mechanism....
    By omega63 in forum Bodywork & Interior
    Replies: 11
    Last Post: 26th April 2011, 21:11
  2. Wiper linkage problem!!!!1
    By saga10 in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 13th November 2010, 20:51

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •