User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: Balls.... P0621 error on 06'/40k 1.9cdti (120), sounds expensive....

  1. #1
    Regular Member Sierra2's Avatar
    Join Date
    Sep 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRI

    Engine : 1.9cdti (120)

    Year : 2007

    Mileage : 45k

    Exclamation Balls.... P0621 error on 06'/40k 1.9cdti (120), sounds expensive....

    Any one put this into English please??


    Generic OBD Error Code Details for P0621



    Generator Lamp/L Terminal Circuit


    What does this mean?

    OBD Code P0621refers to
    The Engine Control Module (ECM) or Powertrain Control Module (PCM) uses the generator turn on signal circuit to control the load of the generator on the engine. A high side driver in the ECM/PCM applies a voltage to the voltage regulator. This signals the voltage regulator to turn the field circuit ON and OFF. The ECM/PCM monitors the state of the generator turn on signal circuit. The ECM/PCM should detect low voltage on generator turn on signal circuit when the ignition is ON and the engine is OFF, or when the charging system malfunctions. With the engine running, the ECM/PCM should detect high voltage on the generator turn on signal circuit. The ECM/PCM performs Ignition ON and RUN tests to determine the status of the generator turn on signal circuit.

    Symptoms

    Possible sumptoms of OBD code P0621
    - Engine Light ON (or Service Engine Soon Warning Light)

    Causes

    Possible causes of OBD code P0621
    - Generator circuit - Generator circuit short to fround - Generator circuit open/high Resistance - Generator circuit short to voltage - Bad generator/alternator - Faulty ECM/PCM The Error code is generally activated on detection of the following conditions: - During the Ignition ON test, the ECM/PCM detects high voltage on the generator turn on signal circuit for 5 seconds. - During the RUN test, the ECM/PCM detects low voltage on the generator turn on signal circuit for 15 seconds.

    Possible Solutions

    - Replaced alternator/generator

  2. #2
    Regular Member C-Owner's Avatar
    Join Date
    May 2011
    Location
    South London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Sierra2 View Post
    Any one put this into English please??




    - Replace alternator/generator
    Its there in plain english

  3. #3
    Regular Member Sierra2's Avatar
    Join Date
    Sep 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRI

    Engine : 1.9cdti (120)

    Year : 2007

    Mileage : 45k

    Default

    Should have mentioned, I don't have a EML on the dash or any problems with starting/running. Only flagged up because matey wanted to test out his ex demo, 5k Snap On diagnostic tool...

  4. #4
    Regular Member DTi Elite's Avatar
    Join Date
    May 2012
    Location
    county durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Elite

    Engine : 1.9 cdti 150

    Year : 2007

    Mileage : 145k

    Default

    might be an old code then , someone might have replaced the alternator & not cleared the fault from the memory .

  5. #5
    Regular Member Sierra2's Avatar
    Join Date
    Sep 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRI

    Engine : 1.9cdti (120)

    Year : 2007

    Mileage : 45k

    Default

    It's annoying that the world of Canbus and codes couldn't include a 'time and date stamp' log to boot....... GRRRRR!

  6. #6
    Regular Member Sierra2's Avatar
    Join Date
    Sep 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRI

    Engine : 1.9cdti (120)

    Year : 2007

    Mileage : 45k

    Default

    For clarity, she starts like a bag of **** first time in the morning, but great once warm. I had that down as the leak off pipes, any chance this could be related?

  7. #7
    Regular Member C-Owner's Avatar
    Join Date
    May 2011
    Location
    South London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    That fault code is non related.

    There's many threads related to poor cold starting 120's

    Battery
    Starter motor
    Glow plugs
    Temp sensor
    Leak off pipes
    Fuel filter
    Fuel filter housing

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. oh..********..sounds expensive
    By Guinea in forum Engine & Drivetrain
    Replies: 19
    Last Post: 19th November 2011, 09:26
  2. Fault Code P0621-01 - Generator Lamp....
    By alcutler in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 5th March 2011, 22:36
  3. signum 1.9cdti sounds like a turbo petrol why??
    By bangty 1 in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 28th September 2010, 18:14
  4. signum 1.9cdti 150 6speed error code u2103
    By shah1 in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 12th December 2009, 08:21

Visitors found this page by searching for:

p0621 vauxhall 1.9 cdti

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •