User Tag List

Thanks Thanks:  0
Likes Likes:  1
Results 1 to 5 of 5

Thread: [Vectra C 2.2 DTR 2003] New Turbo, error P0100 over and over.

  1. #1
    New Member
    Join Date
    Aug 2012
    Location
    Poland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default [Vectra C 2.2 DTR 2003] New Turbo, error P0100 over and over.

    Hello,

    I have a problem with which i can't manage. Two weaks ago I have replaced old turbo with new one. It went great, no problems and leaks. I also had old rubber high pressure pipes very old and leaking so i bought new ones. So for the moment i still have one problem.

    After cleaning error car goes ok for ex. 5 -15 km. And then it goes in service mode. Or it rides a day pretty good but after a while it starts to have a lot less power and poor driveablity.

    The error code that runs service mode is P0100 (67).

    On iddle MAF sensor show such live data:
    desired mass air flow - 70 kg/h
    mass air flow 160-170 kg/h
    mass air flow 1.10-2.0 V

    While riding and going around 2000-3000 rpm the
    mass air flow goes up from 170 to 250, 350 , and at maximum rpm is at 430~.
    voltage goes up to 4.3v
    desired mass air flow is at beginning at 110~ and goes up to 230 and suddenly at gigher speeds it goes rocksolid 20 (maybe data steaming bug)


    Any ideas?
    Last edited by Hubis; 14th November 2012 at 21:06.

  2. #2
    Regular Member C-Owner's Avatar
    Join Date
    May 2011
    Location
    South London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Maf ?

  3. #3
    Regular Member DTi Elite's Avatar
    Join Date
    May 2012
    Location
    county durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Elite

    Engine : 1.9 cdti 150

    Year : 2007

    Mileage : 145k

    Default

    could be a boost leak

  4. #4
    New Member
    Join Date
    Aug 2012
    Location
    Poland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Boost leak? You mean the pipes, intercooler after the turbo, where is high pressure ? I see that egr i leaking a litlle throu the shaft.

  5. #5
    New Member kaloyanpopoff's Avatar
    Join Date
    Apr 2017
    Location
    Bulgaria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel

    Trim : Signum

    Engine : Y22DTR

    Year : 2003

    Mileage : 212000

    Default Solution

    I know this is an old one but people might try and surch that one on google ending up on this thread with no answer. So, the solution is basically one - swirls flaps with two possible problems. First one is I don't know if it correct in English - bended flaps, not good shape, messing up with the air flow. The second one is bad solenoid control valve for the flaps. Best decision is to remove them from the ECU software. Eventually but very rarelly the problem could be the EGR valve stucking in open position. But this would throw an EGR fault code on the ECU also.

    Cheers!

  6. Likes Teapot liked this post

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. PLEASE HELP ERROR CODE p0100
    By signum_05 in forum Vectra C / Signum Troubleshooting
    Replies: 3
    Last Post: 20th December 2012, 20:20
  2. PLEASE HELP!! Error codes p0100 & p0105
    By signum_05 in forum Vectra C / Signum Troubleshooting
    Replies: 5
    Last Post: 1st December 2012, 13:32
  3. Flaming P0100 Error again
    By richje100 in forum Engine & Drivetrain
    Replies: 9
    Last Post: 18th February 2011, 23:23
  4. Replies: 6
    Last Post: 3rd September 2009, 16:40
  5. Vectra C 2.2DTH P0335 P0638 P0100 DTC
    By leemcc in forum Engine & Drivetrain
    Replies: 2
    Last Post: 25th July 2006, 13:58

Visitors found this page by searching for:

Opel DTC P0100-67

p0100(67)

vectra 2.2 dti po100

2.2 dtr

z17dth p0100 67

opel p0100-67

p0100-67 opel

p0100-67 opel vectra c

p0638 p0100 opel vectra c 2.2

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •