User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: power loss on a 54 plate 1.9cdti 8v

  1. #1
    New Member
    Join Date
    Jul 2010
    Location
    darlington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default power loss on a 54 plate 1.9cdti 8v

    have problem was shuddering at low speed and when up to speed about 65mph warning light comes on spanner and bonnet light a drop in power goes off after a couple of seconds but a bit hairy when over taking
    drop me a line if anyone has had this problem and let me know what it could be
    had the car on comp says bad glow plug wire ?but this has never been a problem before

    alistair

  2. #2
    Regular Member carperjake's Avatar
    Join Date
    May 2010
    Location
    Scunthorpe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Elegance CDTi 120

    Engine : 1.9

    Year : 05

    Default

    Check the hoses at the front right of the engine for a split, loads of info on here about it.

    http://www.vectra-c.com/forum/showth...ght=turbo+hose

  3. #3
    Regular Member MrDerv's Avatar
    Join Date
    Nov 2011
    Location
    North East (Beamish)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Check the EGR isn't caked with soot, if it is, give it a clean with Carb cleaner

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, 1.9cdti sri 150
    By Lee_Pike in forum Engine & Drivetrain
    Replies: 22
    Last Post: 16th May 2012, 23:08
  2. 1.9cdti judder and loss of power then fine.
    By voxvectra7 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 27th September 2011, 23:42
  3. 1.9cdti loss of power & smoke
    By nrthwd stu in forum Bodywork & Interior
    Replies: 1
    Last Post: 9th June 2010, 12:52
  4. 1.9CDTi Major Power Loss
    By GlennM in forum Engine & Drivetrain
    Replies: 23
    Last Post: 22nd May 2010, 21:59
  5. help needed LOSS OF POWER 1.9CDTI
    By vectra666 in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 17th January 2009, 20:06

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •