User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: flat spot between 1000 - 2000RPM

  1. #1
    Regular Member
    Join Date
    Aug 2012
    Location
    Stockton-on-Tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default flat spot between 1000 - 2000RPM

    I know theres a right up on this about the BCS valve and i have cleaned the little filter on the side of it and to my disappointment it looked fairly clean and doesnt appear to of done anything really..

    Iv just cleaned the EGR valve its self but looking into the inlet from the EGR it looks incredibly blocked up.. Iv put a blanking plate on the EGR now as well so im not sure if it is that.

    is it possible that it could be the BCS still but it needs fully stripping?

    its a bit annoying as its seems to be when i want to accelerate to over take something the car seems to hesitate for a second and very slow on pick up but then the power comes through.

    any ideas to what else could cause it?

    cheers Craig

    sorry iv put this in the wrong section
    Last edited by craig20102010; 3rd November 2012 at 19:58.

  2. #2
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    Clean the boost sensor, next to the EGR

  3. #3
    Regular Member
    Join Date
    Aug 2012
    Location
    Stockton-on-Tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by tony-1977 View Post
    Clean the boost sensor, next to the EGR
    thats next on my list.. i just couldnt get it off today....due to lack of tools....

    new inlet manifold is hopefully going on this week, parts sitting at home as the swirl vanes are all over the place. I had fixed them once but the actuator rail has come off and its leaking out the top of each vane and i need a good seal for when the engine is remapped.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Flat spot :(
    By marc vectra sri in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 13th August 2012, 19:06
  2. Flat spot
    By marc vectra sri in forum The 'Off Topic' room
    Replies: 1
    Last Post: 12th August 2012, 19:38
  3. Replies: 0
    Last Post: 8th August 2011, 16:39
  4. 1.9 150 Flat between 1000-1700~
    By Homer in forum Engine & Drivetrain
    Replies: 1
    Last Post: 28th June 2011, 17:55
  5. Flat spot!
    By bigknill in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 24th July 2009, 09:43

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •