User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2

Thread: airlock or ??

  1. #1
    Regular Member
    Join Date
    May 2012
    Location
    wirral
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default airlock or ??

    had my water pump and cambelt changed yesterday,all my heaters are red hot and it runs spot on , the only thing im concerned with is the temp gauge only runs up to roughly 82 degrees and falls back down to about 75/78 degrees but when i give it a bit of right foot it rises again but never past 82 degrees , before i had the work done it always ran 85-87 degrees regardless of motorway driving or round town , obviously when the water pump went it ran cold heaters and temp was on 100 plus degrees , i dont think the thermostat has gone its to coincidential to go the day after water pump fell apart , so guys does it sound like its got a bit more air locked in system ? really want it running at right temp again

    cheers mike

  2. #2
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sounds like a dying thermostat mate.

    ---Sent from my iPhone 4 using Forum Runner

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Radiator heating ?airlock? HELP
    By littlesxi in forum Engine & Drivetrain
    Replies: 6
    Last Post: 25th February 2009, 20:58

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •