User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: Just been to test drive a 2.0 turbo Signum, info needed.

  1. #1
    Regular Member
    Join Date
    Jul 2010
    Location
    Sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Just been to test drive a 2.0 turbo Signum, info needed.

    Hi,

    Just been and test drove a 2.0T signum and theres a couple of niggling thoughts going through my head...

    firstly, on start up a slight rattle was heard - chain problem??

    Secondly, after the 2 second rattle the engine is really smooth and quite but doesnt pull like i'd have expected but having never driven a 2.0 turbo dont really know what to expect. Any 2litre owners care to share their experiences with me?

    And finally the clutch was lighter than my 1.8vvt but the biting point a bit higher, something to be concerned about??

    Other than that it was in great condition and drove spot on.

    Any info on the points above or anything else on the 2.0T would be great.


  2. #2
    Regular Member Beardy's Avatar
    Join Date
    Oct 2012
    Location
    Thetford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Astra

    Trim : Elite

    Engine : 1.7 CDTI

    Year : 2004

    Mileage : 110,000

    Default

    I bought one last saturday and have to say my clutch seems high too but it doesnt slip so may be how the are, and after a service shes alot smoother and picks up 100% better. As for the rattle im not sure but other members will be able to help out with that question.

  3. #3
    VIP-Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum & Insignia

    Trim : Elite

    Engine : POS derv

    Year : 2014

    Default

    The engine is pretty bullet proof and can take a proper beating, trust me on that.

    Mine used to do that rattle on start up. A good engine flush and good oil sorted that out. I change rhe oil every 6 months or 5k anyway.

    The car you drove sounds like its in standard form and needs a service that's all. Its a saab engine that is detuned. You can easily get it running a little spritlier as there is plenty of info on this forum for that car/engine.

    I have tuned the nuts of mine and love it.

  4. #4
    VIP-Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum & Insignia

    Trim : Elite

    Engine : POS derv

    Year : 2014

    Default

    What milage and year is it?

  5. #5
    Regular Member
    Join Date
    Jul 2010
    Location
    Sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks for all your replies so far... its 06 on 54K miles and in elite spec, beautiful car just that rattle that made me nervous. I've had a chain driven car before and vowed never to have another - jumped a tooth! lol until I saw this one advertised haha

  6. #6
    Regular Member Keefyb007's Avatar
    Join Date
    Jan 2010
    Location
    Berkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I do not want to tempt fate here, (mine or yours) but any problems with my 2.0T siggy (04 64k) is usually related to the standard Vectra stuff like suspension. The Z20NET is not the problem just the other stuff. BUT if you get a gut feeling I would go with it!

  7. #7
    Regular Member
    Join Date
    Jul 2010
    Location
    Sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Keefyb007 View Post
    I do not want to tempt fate here, (mine or yours) but any problems with my 2.0T siggy (04 64k) is usually related to the standard Vectra stuff like suspension. The Z20NET is not the problem just the other stuff. BUT if you get a gut feeling I would go with it!
    Yeah from info on here the engine seems a strong engine, like my 1.8vvt but Ive prob had more springs and droplinks than hot dinners lol!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Coilovers for signum info needed please
    By Iezzi-martin in forum Engine & Drivetrain
    Replies: 3
    Last Post: 22nd October 2010, 12:43
  2. Signum Test Drive!
    By maurauth in forum Vectra C / Signum Car Chat
    Replies: 24
    Last Post: 29th December 2009, 21:35
  3. test drive need info!!!
    By mitch in forum Vectra C / Signum Car Chat
    Replies: 24
    Last Post: 21st December 2009, 22:39
  4. Signum Test Drive
    By MRLUBBERLUBBER in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 14th September 2008, 09:54

Visitors found this page by searching for:

vectra c 2.0t engine flush www.vectra-c.com

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •