User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: oil light

  1. #1
    Regular Member jamiedvvt's Avatar
    Join Date
    Sep 2012
    Location
    Inverclyde
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Vectra

    Trim : Sri

    Engine : 1.8 vvt

    Year : 2008

    Default oil light

    After changing the oil and filter yesterday i have now noticed the oil light takes about 5 seconds to go off from cold or being stood a while i used 5/30 fully synthetic, never noticed it before i changed to oil is this something to worry about or just me being paranoid no weird noises or that and oil level is fine checked twice to make sure 1.8 vvt engine

  2. #2
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Did you use a genuine oil filter?

  3. #3
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default



    The filter could be emptying while the engine is off, meaning it will take about 5 seconds to re-fill once you start the car, hence the delay in the light going out

  4. #4
    Regular Member jamiedvvt's Avatar
    Join Date
    Sep 2012
    Location
    Inverclyde
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Vectra

    Trim : Sri

    Engine : 1.8 vvt

    Year : 2008

    Default

    No was one from euro i got was going to change it next week as the old oil filter was in bits when i removed the cover will it be okay to use til next week without causing problems ?

  5. #5
    VIP-Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    37 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    The vvt has a paper element filter so the oil all drains back anyway. It is possible that because the filter had collapsed that it was keeping the filter housing full of oil. A few vvt owners have noticed it take a few seconds for the oil light to go out. One thing I would say is do not be tempted to rev the engine while the light is on.

  6. #6
    Regular Member VVT-i-MATT's Avatar
    Join Date
    Feb 2012
    Location
    Calne UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by jamiedvvt View Post
    After changing the oil and filter yesterday i have now noticed the oil light takes about 5 seconds to go off from cold or being stood a while i used 5/30 fully synthetic, never noticed it before i changed to oil is this something to worry about or just me being paranoid no weird noises or that and oil level is fine checked twice to make sure 1.8 vvt engine
    Same thing happens on mine... I guess it always happened, just I noticed it the first time I did an oil and filter change. I use genuine filters and the same thing happens. It just drains out of the system over night.
    I use Magnatec to try and help first start engine wear...

    Matt

  7. #7
    Regular Member Ben50n's Avatar
    Join Date
    Dec 2011
    Location
    Seaham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine is the same, takes a few seconds for the oil light to go out, it could actually be due to a sticky oil pressure switch??

  8. #8
    Regular Member jamiedvvt's Avatar
    Join Date
    Sep 2012
    Location
    Inverclyde
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Vectra

    Trim : Sri

    Engine : 1.8 vvt

    Year : 2008

    Default

    Well not to worried about it now then as a few others do it, thanks guys i thought something was wrong with the car

  9. #9
    Regular Member Ben50n's Avatar
    Join Date
    Dec 2011
    Location
    Seaham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I admit I was concerned about it as I also had trouble with the VVT Cam Phaser solenoids. I flushed the engine, new oil and filter and it has not made any difference to the time the light goes out.

    The filter will drain as there does not appear to be any anti-return valve.

    Best advice is to start it normally and let the light go out before revving the engine.

  10. #10
    Regular Member jamiedvvt's Avatar
    Join Date
    Sep 2012
    Location
    Inverclyde
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Vectra

    Trim : Sri

    Engine : 1.8 vvt

    Year : 2008

    Default

    yeah i always do mate thanks for the advice i don't normally drive anywhere for a few mins as need to demist the windows which is the biggest problem with my car lol

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Replies: 4
    Last Post: 18th August 2012, 08:58
  3. Replies: 17
    Last Post: 16th August 2012, 10:07
  4. No throttle, traction control light, engine management light
    By si260188 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 9th May 2010, 21:45
  5. Fitted rear light,illuminated sunvisors and map reading light
    By glenboy in forum Vectra C / Signum Car Chat
    Replies: 26
    Last Post: 30th March 2008, 10:51

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •