User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Engine light help asap

  1. #1
    Regular Member VikingLammy's Avatar
    Join Date
    May 2012
    Location
    Woolwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Vxr

    Trim : Vxr

    Engine : 2.8 (280)

    Year : 2007

    Mileage : 59.000

    Default Engine light help asap

    going down the road 2 miles my 1.8vvt sri vectra suddenly starts shakeing as im putting on the gas, then realise my engine light has come on. This is exactly what happened to my mk4 astra and had found out it was a spark plug. Ive just check them and they still look really good. Anyone got any ideas what his could be. My wifes pregnant and is due tomorrow so really need this sorted asap!!

  2. #2
    Regular Member Chris SRi's Avatar
    Join Date
    Jan 2011
    Location
    Barrow In Furness, Cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Need to get the codes read, otherwise you could be wee'ing in the breeze!

    Could be coilpack though if it felt like it did when it was a spark plug.

  3. #3
    Regular Member VikingLammy's Avatar
    Join Date
    May 2012
    Location
    Woolwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Vxr

    Trim : Vxr

    Engine : 2.8 (280)

    Year : 2007

    Mileage : 59.000

    Default

    I just bought one off of ebay, should be here monday. Garages charge loads dont they?

  4. #4
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    What you're describing could most probably be a plug going off, or a coil pack failing.

    Really need the codes read for a definite answer though. Main dealers rip you off for fault code reads. Try a smaller independent if you're in a hurry, should be cheaper.

  5. #5
    VIP-Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    You can do the pedal test on the 1.8 to read the codes

  6. #6
    Regular Member
    Join Date
    Jul 2011
    Location
    teesside
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats



    Engine : Z18XER

    Year : 2008

    Default

    some fault codes here http://www.vectra-c.com/forum/showth...s-Vauxhall-TIS coil pack for 1.8vvt is around £150 from the stealers. I got non genuine from local parts place for around £53

    how to http://www.vectra-c.com/forum/showth...-any-Equipment

  7. #7
    Regular Member VikingLammy's Avatar
    Join Date
    May 2012
    Location
    Woolwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Vxr

    Trim : Vxr

    Engine : 2.8 (280)

    Year : 2007

    Mileage : 59.000

    Default

    ive done the pedal test but doesnt flash or nothing, will take a visit to the garage in the morning

  8. #8
    Regular Member Envy's Avatar
    Join Date
    Jun 2010
    Location
    Welwyn Garden City
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRi Nav

    Engine : 1.8 VVT

    Year : 2006

    Mileage : 130k

    Default

    Had the same problem.

    Changed plugs to no effect.

    Bought a second hand coilpack and it sorted it.

    Your problem could be :-

    Maf Sensor faulty

    Blocked up fuel filter

    Coilpack

    Spark plugs

    Im betting on coilpack or fuel filter though but thats just a guess. Im no expert.

  9. #9
    Regular Member VikingLammy's Avatar
    Join Date
    May 2012
    Location
    Woolwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Vxr

    Trim : Vxr

    Engine : 2.8 (280)

    Year : 2007

    Mileage : 59.000

    Default

    my scanner come this morning, plugged it in and says p0302 cylinder 2 misfire detected. Is this spark plug? they looked fine to me tho

  10. #10
    VIP-Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    Well id definitely try a set of plugs first, really not worth changing just 1 unless you've changed them within the last couple of months. If that doesn't help, its most likely the coil pack.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. interior light help asap please
    By simplesi in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 10th November 2012, 17:06
  2. Replies: 17
    Last Post: 16th August 2012, 10:07
  3. Emmissions light on. Help needed asap
    By stokie-lee in forum Engine & Drivetrain
    Replies: 1
    Last Post: 29th July 2010, 12:00
  4. Replies: 3
    Last Post: 28th April 2009, 19:49

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •