User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: spanner light while under acceleration help

  1. #1
    Regular Member
    Join Date
    Nov 2010
    Location
    Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Cdti 150

    Trim : Sri

    Engine : 1.9

    Year : 2004

    Mileage : 82000

    Default spanner light while under acceleration help

    Hi guys hope someone can help me out. Bought my Vectra cdti 150 preface 4 weeks ago and got a warranty with it, since then its been in the garage for new inlet manifold due to the swirl bar fault,new alternator as my power steering failednew thermostat and just got it back from having the duel mas flywheel done, which wasn't covered under warranty. It went to the garage due to the spanner light coming on while I was accelerating which in turn lost power. So got it back yesterday ( after a week ) asked the mechanic if everything was fine and they said yes. Fetching it back home yesterday and it now seems down on power,it has a rattle to it which wasnt there before and the spanner light came on again. Any help will be gratefull as the garage has had the car longer than I have and its 30 miles to take it to the garage for the warranty and Im now getting fed up

  2. #2
    Full Member bobssignum's Avatar
    Join Date
    Dec 2007
    Location
    polishing something or other somewhere
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum 2.0 DTi

    Trim : Elegance/Elite

    Engine : 2.0DTi

    Year : 2003

    Mileage : 73350

    Default

    Stewsy
    There are far to many possibilities for what is causing your spanner light to come on .
    You will need to have the fault codes read to diagnose what the problem is likely to be
    Just ask on here if there is anyone near with a code reader who may be able to help you out in this matter
    but in the mean time check all your hoses for tightness also check your vacuum hoses have been connected properly .
    garages are no saints and are more than capable of puting a car back together wrongly (from personal experience ).
    Driving vauxhall,s for 30 + years
    and still loving it

  3. #3
    Regular Member alcutler's Avatar
    Join Date
    Nov 2010
    Location
    East Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c 1.9cdti 120 estate

    Trim : design



    Default

    You have obviously had most of the more common problems sorted by the sound of it - but if your not happy with the car you would certainly have good grounds to take it back and ask for a refund - if they have had it more times than you it isn't 'fit for purpose' - although if you have gone to the expense of replacing the flywheel it might be worth seeing it through now. As stated above you need a diagnostic check to give you some indication of what's causing your latest problem - good luck with it.

  4. #4
    Regular Member
    Join Date
    Nov 2010
    Location
    Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Cdti 150

    Trim : Sri

    Engine : 1.9

    Year : 2004

    Mileage : 82000

    Default

    My mate who is a mechanic told me the flywheel was on its way out and also put his code reader on and it came up with P0960 Rail Pressure Control Circuit Open, P1125 Throttle Actuator Circuit Open. So when I took it to the garage I told them that the flywheel was knackered and showed them the codes as I took a photo of the code reader displaying the codes and they said that they would sort it. Got the car back yesterday after a week in the garage and the spanner light is still coming on but there are no codes stored..the spanner light comes on under acceleration which causes the car to lose power for about 10 seconds when i take my foot off the accelerator then goes off again..
    Last edited by stewsy; 1st November 2012 at 09:57.

  5. #5
    Regular Member
    Join Date
    Nov 2010
    Location
    Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Cdti 150

    Trim : Sri

    Engine : 1.9

    Year : 2004

    Mileage : 82000

    Default

    Just had a go up and down a bypa near us and after 10 mins the spanner light finally came on...so pulled over as quick as i could and read the ecu via opcom before the spanner light went off again and the fault code is now P2279-11 Intake Air Leak Detected..any idea where I should be looking guys ????

  6. #6
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    Check the air box and pipework from the air box.

    Also check the boost pipe on the right hand side for splits.

    And the EGR gasket may be leaking a little as well.

    HTH

  7. #7
    Regular Member
    Join Date
    Nov 2010
    Location
    Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Cdti 150

    Trim : Sri

    Engine : 1.9

    Year : 2004

    Mileage : 82000

    Default

    Checked all pipe work and all looks fine, the boost pipe is a bit spongy though, is this normal ?? I am going to take off the egr over the weekend and give it a clean see if that works...thanks for all the info guys

  8. #8
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : ls

    Engine : 1800

    Year : 04

    Mileage : 128000

  9. #9
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : ls

    Engine : 1800

    Year : 04

    Mileage : 128000

    Default

    http://www.vectra-c.com/forum/showth...ult-code-P2279

    post 6

    try to strip the Solenoid side of the EGR to resolve this

  10. #10
    Regular Member
    Join Date
    Nov 2010
    Location
    Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Cdti 150

    Trim : Sri

    Engine : 1.9

    Year : 2004

    Mileage : 82000

    Default

    All sorted now, it was the turbo intercooler which had a hole in it and also the turbo was fubbered. Just got it back from garage and everything done under warranty so happy bunny

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. EGR Valve, Engine Management Light & Spanner Light
    By guygreen in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th December 2010, 20:09
  3. Jerky acceleration / Car with spanner light
    By danman487 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 8th July 2010, 14:31
  4. Replies: 8
    Last Post: 7th April 2009, 10:58
  5. CDTI 150 Spanner on Acceleration
    By b-e-r-t in forum Engine & Drivetrain
    Replies: 7
    Last Post: 8th September 2007, 21:25

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •