User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Airbag light staying on longer after the car has started

  1. #1
    Regular Member WeDesign's Avatar
    Join Date
    Jun 2006
    Location
    Vectra-C.com
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Design

    Engine : CDTi 150

    Year : 55

    Default Airbag light staying on longer after the car has started

    CDTi 150

    Since this cold weather the last 2 days the airbag light stays on for bout 10 seconds after the engine has started, it never was like this.

    Battery was replaced 3 months ago, any ideas if this is the start of another issue?


    Regards.

  2. #2
    Regular Member dilan's Avatar
    Join Date
    Aug 2009
    Location
    dudley, west midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mines the same mate, been like it a couple of months, it stays on for about 8-10 seconds then goes out,,, no problems with my car..... I wouldn't worry to much,,, ,, and as you say , it seems worse in the damp and cold...

    Sent from my iPhone using Forum Runner

  3. #3
    Regular Member WeDesign's Avatar
    Join Date
    Jun 2006
    Location
    Vectra-C.com
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Design

    Engine : CDTi 150

    Year : 55

    Default

    What have happened a few times recently is once I turn the ignition on, the car completes the checks and all lights go out.

    When I then start the engine and it fires up the ABS and Anti skid light comes back on for a second or 2.

    Any ideas why this is happening, it only seems to happen when it is cold.


    Regards.

  4. #4
    Regular Member WeDesign's Avatar
    Join Date
    Jun 2006
    Location
    Vectra-C.com
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Design

    Engine : CDTi 150

    Year : 55

    Default

    no offers on this?

  5. #5
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    Quote Originally Posted by Sebastian B View Post
    When I then start the engine and it fires up the ABS and Anti skid light comes back on for a second or 2.
    Mine did this yesterday. Never before. Was fine today though

  6. #6
    Regular Member WeDesign's Avatar
    Join Date
    Jun 2006
    Location
    Vectra-C.com
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Design

    Engine : CDTi 150

    Year : 55

    Default

    Quote Originally Posted by Sebastian B View Post
    What have happened a few times recently is once I turn the ignition on, the car completes the checks and all lights go out.

    When I then start the engine and it fires up the ABS and Anti skid light comes back on for a second or 2.

    Any ideas why this is happening, it only seems to happen when it is cold.


    Regards.
    This happened again this morning ...

    any ideas why this happens?


    Regards

  7. #7
    Regular Member
    Join Date
    Aug 2012
    Location
    basingstoke
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    same as mine,noticed it a few weeks ago when iut was cold and damp.I recon its got something to do with the damp aswell

  8. #8
    Full Member GazVXLINE170's Avatar
    Join Date
    Jun 2007
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : SRI VX-Line Nav

    Engine : 2.0 CDTI [170 PS]

    Year : 2015

    Mileage : 27000

    Default

    Unplug th ABS connector and reconnect as sometimes that resolves issues.
    Insignia VX-Line Nav CDTI 170.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Airbag Light staying on
    By nigelminiowner in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 23rd July 2012, 20:51
  2. Oil light staying on
    By Jamesie82 in forum Engine & Drivetrain
    Replies: 18
    Last Post: 12th May 2012, 22:31
  3. AIRBAG light .. is thier a fuse the the Airbag ecu ?
    By Steven T Davies-Moss in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 10th September 2011, 13:21
  4. TC and ABS light staying on?
    By JonSRi150 in forum Engine & Drivetrain
    Replies: 6
    Last Post: 31st December 2009, 22:10
  5. Battery Light Staying on
    By phil67 in forum Electrical & ICE (including SatNav)
    Replies: 10
    Last Post: 3rd April 2009, 21:22

Visitors found this page by searching for:

vectra c sometimes airbag light

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •