User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: new problem,2005 2.2 sri car cut out after putting fuel in

  1. #1
    Regular Member taffy bhoy's Avatar
    Join Date
    Aug 2008
    Location
    newport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default new problem,2005 2.2 sri car cut out after putting fuel in

    car is a 2005 2.2 petrol sri

    bit of a read, but here goes
    car has run sweet as a nut for the last 2 weeks we have had it, stopped for fuel today, stuck £30 in, start car up, spanner light comes on, get about 50yds down the road and car cuts out on me, it didnt matter what i done with the throttle, it just died. couldn't get it started for a minute or 2, and when it did, it was fine for about 10secs, light come on again, another 10 seconds later it dies again.
    aa guy comes out checks that the car is getting fuel which it was, tried reading the fault code, but said his code reader wasnt that good for vx codes, checked a few other bits and bobs, all looked fine, disconnected battery, and fired it up, car ran fine for about 5mins, then light came back on then car cut out again when i drove of.
    its now been towed to a local garage who has a vx reader, so going to hear from them tomorrow.
    car will always start after a minute or so, fires up fine and runs fine, until light comes on and it cuts out again
    i have phoned sainsburys to see if they have had any issue with dodgy fuel, but they say no problems, but does seem odd, that it started straight after refueling, but might just be conincidence

    any ideas or common issues with these?
    and no i didnt put diesel in

    garage came up with these stored codes

    p0136 02 sensor high voltage
    p0115 engine coolant temperature circuit
    p1112 swirl flap
    p1191 fuel rail pressure sensor circuit malfunction

    he started it up this morning it idled fine this morning, got up to temperature fine, ran for a good 10 minutes on idle, then once revved light came on and cut out, re read the codes and only the bottom one p1191 came up.
    he seems to think its the fuel pressure regulator causing the fault, but wants to investigate it properly before spending out on parts

    i also phoned vx asking them about recalls on the 2.2 regarding fuel pumps and fpr, and apparantly mine isnt one of the effected, the only recall due on mine is for the handbrake.

    does it sound like he is right? could it be something as simple as crap in the system and a simple fuel filter change will sort or can i push vx into admitting this fault may apply to my car if the garage do confirm one of them to be at fault?

  2. #2
    Regular Member Graham's Avatar
    Join Date
    Sep 2005
    Location
    Macclesfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Focus

    Trim : Titanium

    Engine : 1.6 TDCI

    Year : 62

    Mileage : 9K

    Default

    Why not just change the fuel filter anyway for what it is, not a big job and not expensive either, then see if its cured the problem. It could be dodgy fuel from supermarkets, one reason i only use Shell or BP.

  3. #3
    North West Regional Organiser paulvectrac's Avatar
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    35 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    It will be the fuel pressure regulator making it cut out matey
    Vectra vxr custome remaps egr deletes dpf and diagnostic work all remaps are custome bench tuning avalible all genuine equipment PM for info

  4. #4
    Regular Member
    Join Date
    Jun 2011
    Location
    wolverhampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Crank sensor playing up when hot?

  5. #5
    Regular Member taffy bhoy's Avatar
    Join Date
    Aug 2008
    Location
    newport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i'm going to get them to change the filter anyway, i have done a service on it apart from that, so good to do either way. to be completly honest, i cant say i have ever bought into this supermarket fuel is bad talk, i have driven many different cars over the years, some powerful, some standard and never had any issues, but saying that, i do belive it must have been something to do with this refuel that has caused the problem, to me its just too much of a coincedence that i fuelled up, the the light came on the first time i started it up afterwards. i dont know how the fuel pump or regulator faults show themselves, but from the posts i have read it seems a random thing, traveling down the motorway etc, so why as soon as i refuel? could some crap have been sucked through and effected the filter/pump/regulator?

    as for the crank sensor thought, i did consider that as i have heard of these sort of faults with the sensor breaking down when hot, but no fault code is showing up for that or the cam sensor?

  6. #6
    New Member
    Join Date
    Aug 2012
    Location
    Bedfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hey taffy, I've had a similar fault on a 2.2 Direct Signum lately. Have a read on VVOC to save me repeating myself. http://www.vvoc.com/forum/showthread.php?t=429502
    But the long and short of it was it was the FPR.

    Nick (aka NIXSIXPOT)

  7. #7
    North West Regional Organiser paulvectrac's Avatar
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    35 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    God am good lol sin it hundreds of times it even happened on my own car
    Vectra vxr custome remaps egr deletes dpf and diagnostic work all remaps are custome bench tuning avalible all genuine equipment PM for info

  8. #8
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : ls

    Engine : 1800

    Year : 04

    Mileage : 130000

    Default

    p1191 fuel rail pressure sensor circuit malfunction

    as paul said
    It will be the fuel pressure regulator making it cut out matey

    i can find you a few threads on this

  9. #9
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : ls

    Engine : 1800

    Year : 04

    Mileage : 130000

  10. #10
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : ls

    Engine : 1800

    Year : 04

    Mileage : 130000

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Radio problem - CDR 2005
    By Ste in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 11th April 2011, 01:40
  2. 1.9 cdti sxi 2005 Fuel metering solenoid valve circuit????
    By Gaz_chandler33 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 4th November 2010, 23:47
  3. Vectra 2.2 direct 2005 Fuel filter
    By caigey in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 16th July 2010, 20:26
  4. Problem...? Vectra SXI...problem with starting after filling with fuel?
    By doozer in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 8th November 2008, 09:40

Visitors found this page by searching for:

vectra c 2.2 cutting out when i put fuel.in it

vectra c 2.2 petrol crank sensor site:www.vectra-c.com

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •