User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: power steering problem

  1. #1
    Regular Member
    Join Date
    May 2011
    Location
    sunderland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default power steering problem

    Morning lads ive got a vectra c cdti 06 plate and the steering is tight it feels like im driving with a flat tyre. Ive topped up the fluid and ive changed tyres no difference and also when turning the wheel wont go back to straight ive got to steer it back. No lights on dash no other faults any ideas anyone??

  2. #2
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Try changing the fluid

    ---Sent from my iPhone 4 using Forum Runner.

  3. #3
    Regular Member john norris's Avatar
    Join Date
    Jun 2012
    Location
    lancashire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    get the alternator tested power for steering comes directly off it

  4. #4
    Regular Member
    Join Date
    May 2011
    Location
    sunderland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Should i check the voltage from the battery because that will show if the alternator is a gonna??

  5. #5
    Regular Member yessof's Avatar
    Join Date
    Jan 2008
    Location
    west yorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Same thing happened to mine a while ago. New battery cured it.

  6. #6
    Regular Member
    Join Date
    May 2011
    Location
    sunderland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Did u check what the voltage was on your battery before you got a new one if so what was the reading??

  7. #7
    Regular Member yessof's Avatar
    Join Date
    Jan 2008
    Location
    west yorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I didn't check it. Wouldn't start, AA checked charge rate and battery. Charge rate ok, battery u/s. Fitted new battery no more steering problems. If you connect a multimeter across the battery terminals it should read a minimum of 14.2 volts with the engine running.

  8. #8
    Regular Member
    Join Date
    May 2011
    Location
    sunderland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Cheers mate ill have a look after i finish work hopefully its only the battery and not a pump or a steering rack!!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Power steering problem
    By Danwells72 in forum Troubleshooting
    Replies: 15
    Last Post: 9th October 2012, 16:25
  2. On Going power steering problem
    By gazspeight in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 29th November 2011, 18:18
  3. power steering problem
    By mr.d in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 9th August 2011, 22:33
  4. Power Steering Problem
    By llaregub in forum Electrical & ICE (including SatNav)
    Replies: 12
    Last Post: 3rd January 2008, 11:35
  5. Power Steering problem
    By H11LGX in forum Suspension, Wheels & Brakes
    Replies: 8
    Last Post: 22nd March 2006, 01:19

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •