User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: Help Please?! thermostat possibly

  1. #1
    Regular Member
    Join Date
    Aug 2011
    Location
    rotherham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Help Please?! thermostat possibly

    Hey everyone, i have a feeling its down to my thermostat but not sure?! the temp needle doesnt move at all even if sat on a motorway for an hour or so! however if sat ticking over the needle does tend to rise, the blowers do get warmish but not hot like they should. I decided to take the plunge thinking it was this and went to purchase a thermostat to find out that appratnly i have to buy the entire houseing i will be picking this up tommorow and dont really no were to start replacing this lol sorry if this is in the wrong section new to this. Its for a 1.8 petrol 52 plate vec c,

    thanks!

  2. #2
    Regular Member
    Join Date
    Jun 2008
    Location
    South east
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like the thermostat is stuck open and keeping the engine too cold. In such cases, driving along at speed doesn't get the engine any warmer, because of the increased airflow through the radiator.

  3. #3
    Vectra-C Enthusiast
    Join Date
    Dec 2011
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had the same on mine a few months ago, changed the thermostat and all fine now. I followed the how2 on here, but obviously changed the whole thing rather than just the sensor. Cant post you the link though because I dont know how to do it, sorry. I didnt drain the radiator first though, I just removed the housing lost some antifreeze and then topped it up after.

  4. #4
    Regular Member alcutler's Avatar
    Join Date
    Nov 2010
    Location
    East Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c 1.9cdti 120 estate

    Trim : design




  5. #5
    Regular Member
    Join Date
    Aug 2011
    Location
    rotherham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    dont think this is for mine as apprantly i can only change the housing as you cant get to the thermostat

  6. #6
    Vectra-C Enthusiast
    Join Date
    Dec 2011
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by alcutler View Post
    Yes it is, thank you
    Oh and I didnt change the clips either, the ones on the pipes are fiddley, but very robust...and trust me they needed to be the amount of time my pliers slipped off. Guess changing to jubilee clips would have made it easier if it ever goes again.

  7. #7
    Vectra-C Enthusiast
    Join Date
    Dec 2011
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by linford View Post
    dont think this is for mine as apprantly i can only change the housing as you cant get to the thermostat
    I change the housing on mine too, but still followed the how2. The removal and replacement is still the same

  8. #8
    Regular Member
    Join Date
    Aug 2011
    Location
    rotherham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    so i could just get the thermostat itslef instead of having to get the entire housing?

  9. #9
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : ls

    Engine : 1800

    Year : 04

    Mileage : 129000

    Default

    Quote Originally Posted by linford View Post
    so i could just get the thermostat itslef instead of having to get the entire housing?
    the thermostat is a common fault on the vectra c

    (this below is what should happen.
    i have replaced it with a new thermostat)
    when you start the car from cold

    if the temperature outside say is reading 15 degress

    the car (petrol) takes about 3 miles to get a reading of 86-89c and stays there it does not move

    (make sure the heater is in the off position)

    mine broke around 53000 miles

    post 15 onwards may help

    http://www.vectra-c.com/forum/showth...g-petrol/page2
    Last edited by vectra ste; 1st October 2012 at 18:06.

  10. #10
    Regular Member
    Join Date
    Aug 2011
    Location
    rotherham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks everyone, i changed the entire housing yesterday. didnt bother draining , all i did was just take the 2 bolts out and disconnect main hose, just sat a bowl underneath, oh and i wouldnt reccomend doing it with a hot engine i thought the anti freeze that had spilled out was gunna set a light with the amount of smoke lol not to mention a few burn marks on hands lol..... but main thing is everything sorted!! the car gets up to temperature and stays there now! even of short journeys and i also have red hot blowers

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Could it possibly be???
    By BigWilko in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 30th December 2012, 20:51
  2. egr possibly?
    By gav_embo in forum Diesel Engine related
    Replies: 9
    Last Post: 4th October 2009, 20:57
  3. MLC possibly ?
    By FIL 4822 in forum Spotted or put a flyer on a Vectra C/Signum?
    Replies: 13
    Last Post: 16th November 2008, 19:07
  4. Possibly a new car for me ?
    By FIL 4822 in forum Vectra C / Signum Car Chat
    Replies: 21
    Last Post: 20th December 2007, 20:30

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •