User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Error codes. Anyone kind enough to advise?

  1. #1
    Regular Member SlowCoach's Avatar
    Join Date
    Jan 2012
    Location
    Houghton Le Spring
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI 150

    Trim : Smart and Bad!

    Engine : Z19DTH

    Year : 2008

    Mileage : 105000

    Default Error codes. Anyone kind enough to advise?

    B1000-39 unknown code

    P0621-02 unknown code

    P1901-75 particulate filter pressure sensor high differential pressure

    P0002-52 rail pressure control range/performance

    What need doing, cost and how long it would take to do. Bearing in mind i'll be doing it myself as in saving costs and gaining experience for myself and helping hands.

  2. #2
    Regular Member SlowCoach's Avatar
    Join Date
    Jan 2012
    Location
    Houghton Le Spring
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI 150

    Trim : Smart and Bad!

    Engine : Z19DTH

    Year : 2008

    Mileage : 105000

    Default

    Anyone???

  3. #3
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP1

    Engine : 1.9 CDTi 150

    Year : 2007

    Mileage : 66000

    Default

    Quote Originally Posted by Humourbash View Post
    Anyone???
    B1000 I think is the SDM (airbag control unit) - could be loose cables/connectors under the seat.

    P0621 - Generator Field "F" Control Circuit Malfunction - could be alternator/battery issue, might be worth checking the volts on the battery engine running/not.

    As for the others, do you have any issues currently with the car? What is the car, CDTi? Auto/Manual?

  4. #4
    Regular Member SlowCoach's Avatar
    Join Date
    Jan 2012
    Location
    Houghton Le Spring
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI 150

    Trim : Smart and Bad!

    Engine : Z19DTH

    Year : 2008

    Mileage : 105000

    Default

    1.9cdti 150 z19dth engine. Goes limp mode 2 minutes after starting and driving. Use excessive fuel, 10-30% than it should. Was half tank yesterday but 30 miles of easy driving, its now 1 bar away from red zone where before would be using half a bar for 30 miles urban!

    Turbo dont tick on when limp goes on meaning excessive fuel burning too much? Turbo replaced, maf checked. Egr cleaned, tbc cleaned, clueless now!!

  5. #5
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP1

    Engine : 1.9 CDTi 150

    Year : 2007

    Mileage : 66000

    Default

    Is it an Estate or an Auto? Basically wondering if it has a DPF, if so this could be the cause of the problem, i.e. blocked or in need of a re-gen.

    EDIT: Just checked your profile, its an estate and will have a DPF, have you had this checked out?

  6. #6
    Regular Member
    Join Date
    Jul 2010
    Location
    Nottingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had the same code P1901-75 particulate filter pressure sensor high differential pressure, same symptoms as yourself, light on every two miles then limp home mode,I cleaned the dpf filter and now its back to normal.

  7. #7
    Regular Member SlowCoach's Avatar
    Join Date
    Jan 2012
    Location
    Houghton Le Spring
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI 150

    Trim : Smart and Bad!

    Engine : Z19DTH

    Year : 2008

    Mileage : 105000

    Default

    Quote Originally Posted by daz_scooby@hotmail.c View Post
    I had the same code P1901-75 particulate filter pressure sensor high differential pressure, same symptoms as yourself, light on every two miles then limp home mode,I cleaned the dpf filter and now its back to normal.
    Yeah keeps going in limp mode so quickly turn off then on to resume normal driving behaviour til limp mode 2 minutes later!! Annoying tho!

    What should i do with this stupid dpf?? The easiest method please.

    As for the fuel rail. What is this??

  8. #8
    Regular Member SlowCoach's Avatar
    Join Date
    Jan 2012
    Location
    Houghton Le Spring
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI 150

    Trim : Smart and Bad!

    Engine : Z19DTH

    Year : 2008

    Mileage : 105000

    Default

    Quote Originally Posted by Dan_BlackSRi View Post
    Is it an Estate or an Auto? Basically wondering if it has a DPF, if so this could be the cause of the problem, i.e. blocked or in need of a re-gen.

    EDIT: Just checked your profile, its an estate and will have a DPF, have you had this checked out?
    No didnt check out but what should i do??

  9. #9
    Regular Member SlowCoach's Avatar
    Join Date
    Jan 2012
    Location
    Houghton Le Spring
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI 150

    Trim : Smart and Bad!

    Engine : Z19DTH

    Year : 2008

    Mileage : 105000

    Default

    Any one know where to get cheapest dpf?? Ebay is at £270! A bit out of my reach!! :-(

  10. #10
    Regular Member C-Owner's Avatar
    Join Date
    May 2011
    Location
    South London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Double post.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. error codes
    By tomo610 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 26th June 2012, 20:33
  2. 3 error codes
    By Hydravox in forum Engine & Drivetrain
    Replies: 11
    Last Post: 20th April 2011, 12:14
  3. Error codes, 2.2
    By Rennie in forum Engine & Drivetrain
    Replies: 1
    Last Post: 10th April 2010, 23:21
  4. Need Some Help...Vec-B Error Codes
    By Vaux-Man-G in forum General Chat
    Replies: 5
    Last Post: 9th April 2009, 08:56
  5. Hello All..... I'm after your help (ERROR CODES)!!!
    By albertoleach in forum Introduce yourself.
    Replies: 12
    Last Post: 9th March 2009, 09:50

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •