User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 5 123 ... LastLast
Results 1 to 10 of 49

Thread: Has anyone had a good ownership experience of CDTi 150?

  1. #1
    Regular Member Lockstock2012's Avatar
    Join Date
    Aug 2012
    Location
    Bristol
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Has anyone had a good ownership experience of CDTi 150?

    Having only joined the forum after buying my 58 plate Sri cdti 150 I'm starting to wonder if I made the right choice - lots and lots of tales of woe regarding the engine. It would be good to hear from people who have had good experiences - and to get any hints on how to avoid trouble.

  2. #2
    North Wales - Assistant Regional Organiser
    Join Date
    Feb 2010
    Location
    Wirral
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    It's a perfectly good engine that has faults the same as others. Not as cheap to fix sometimes but remember the CDTi 150 was the most common engine Vauxhall sold in the Vectra so you will hear about more bad news about them than other engines. Purely because there's more of them to go wrong. Clutches and flywheels they go through, alternators are another favourite as are inlet manifolds. As long as you blank off the EGR or have it mapped out so its not filling the inlet with crap, don't drive it like a bellend all the time and dump the clutch all the time out of junctions it'll just be wear and tear parts same as any other engine.

  3. #3
    Regular Member Chris SRi's Avatar
    Join Date
    Jan 2011
    Location
    Barrow In Furness, Cumbria
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by cont1204 View Post
    don't drive it like a bellend all the time
    That actually made me laugh out loud.

  4. #4
    Regular Member
    Join Date
    May 2009
    Location
    galway
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hi Mate,
    I have a 150 and I love it. I have it since it was 7 months old its 2008.
    Its have the flywheel and altenator done under warranty and now has 125k miles on the clock.I never put its in 6th
    Unless I am doing 75 mph or on them motorway.
    Keep them revs a little bit high its will help them manifold and egr

  5. #5
    Full Member RichM's Avatar
    Join Date
    Sep 2008
    Location
    Bracknell
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)

    Default

    I have a 58 plate 150 and its been absolutely fine. I've had a split intercooler hose in 85k miles. Most of the mods had been done to the late cars like ours so you shouldn't have too many problems.

    Rich

  6. #6
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)

    Default

    People only really post up when they have problems.

    No point it posting: Hey I drove my car all week and it worked as it should lol

  7. #7
    Regular Member
    Join Date
    Nov 2009
    Location
    Warrington
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by lee gsi View Post
    People only really post up when they have problems.

    No point it posting: Hey I drove my car all week and it worked as it should lol
    hahahaha

  8. #8
    Full Member Sebastian's Avatar
    Join Date
    Feb 2008
    Location
    Electric Heated Recaro Leather
    Post Thanks / Like
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)

    Default

    U can always go for a Ford Mondeo

  9. #9
    Regular Member Mission1979's Avatar
    Join Date
    Mar 2009
    Location
    Castleford
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I have a 2005 1.9CDTI and its had all the issues that crop up on here. I have had it three and a half years. I replaced DMF about a year ago £750 including fitting, only appears to have done 30000 miles on last one. Third injector plug send engine into limp mode, EGR blocked so I clean it regularly but have not blocked it just fitted fiat/alfa gaskets. Swirl flaps are glued open after a couple of failed attempts to reinstate it. A new manifold would cost more than the car is worth. I think engine is great, pulls really well and I always drive it hard. Had a 2.5 V6 Omega before and this is a lot better. Most of the issues should have been sorted with your being a late one.

  10. #10
    Regular Member Craig1985's Avatar
    Join Date
    Dec 2007
    Location
    harwich essex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    First one I had from new, 07 reg, owned for 4 1/2 years, only trouble i had was egr at 25k (ish) new one was fine. and the other problems i had were the alternator and starter motor, at about 80k. I sold the at with 115k on.

    2nd car, 23k on clock and now up to 38k only had the CIM changed under warranty. ( my fault for leaning in car to push it forward few inches to open garage Door and broke and broke summat causing steering lock to click.)

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. CDTI 150, all in all a good one
    By galway1 in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 2nd June 2014, 18:08
  2. Well nearly 100k of CDTI 150 Ownership
    By GazVXLINE170 in forum Vectra C / Signum Car Chat
    Replies: 20
    Last Post: 5th June 2011, 15:25
  3. GOOD OLD CDTi
    By Si-SRI in forum Vectra C / Signum Car Chat
    Replies: 20
    Last Post: 3rd February 2011, 12:18
  4. Good experience with tracking!
    By djr69uk in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 24th May 2010, 19:16
  5. Not a good start to Vectra ownership!
    By Boy Lard in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 15th February 2008, 12:35

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •