User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2

Thread: Weird Heater Fan Problem

  1. #1
    Regular Member Bethan39's Avatar
    Join Date
    Jul 2005
    Location
    South Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Weird Heater Fan Problem

    I normally leave my heater fan on number 1 so i can have cold air blowing into the car (except when the wife drives it and she always turns it off) anyway i've noticed now if i turn the fan off it still is on at number 1 speed? all the other speeds work fine there is no difference in the fan being off or turned on at number 1 but 2,3,4 all work as normal i guess it could be the resistor? what do you guys think thanks

  2. #2
    Regular Member
    Join Date
    May 2009
    Location
    Wigan
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Exclusive

    Engine : 1.9 CDTI


    Default

    If you've got the aircon on, the fan doesn't turn off until you turn off the aircon. It could be one of the microswitches inside the heater controls. There is one to turn the fan off & one to turn the fan on full. There is a lobe on the fan speed dial inside the console which acts on these switches. They are only small & quite flimsy looking tbh. My heater did this & it turned out the switch had pretty much worn away. I had to get a console from a scrappy & swap the switches over.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Weird problem with heater blower only works with the lights off
    By evhop in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 4th November 2012, 22:02
  2. Weird clicking noise from heater control or glove box
    By rollercoaster63 in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 17th November 2011, 14:29
  3. Weird problem
    By wayne10244 in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 27th September 2011, 19:12
  4. Weird Heater Problems - Help Please
    By suj786 in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 30th January 2009, 09:44
  5. Weird screen heater behaviour
    By SignumPhil in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 4th October 2007, 12:52

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •