User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Blower seem weak when in direct face mode

  1. #1
    Regular Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Blower seem weak when in direct face mode

    The blowers on the Vec seem really weak when they are blowing directly out the vents.

    When they are blowing out of the top or feet area, they seem fine.

    Is there a known fault to sort this out or it just me being curious?

    They work fine on all 4 settings, just dont seem to blow out powerful enough out the side vents especially.

    Thanks.

  2. #2
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    Totally random question for you, but -

    Does your air-con work?

    When my air-con refridgerant leaked out, the air-con stopped working, but as well as this, the blowers seemed to be alot less powerful.
    Full service was resumed, once the air-con was sorted and regassed.

    Just a thought - not sure if it is related to your issue or just a coincidence in my car.

  3. #3
    Regular Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Air con works fine mate.....another issue?

  4. #4
    Regular Member WeDesign's Avatar
    Join Date
    Jun 2006
    Location
    Vectra-C.com
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Design

    Engine : CDTi 150

    Year : 55

    Default

    I found this the case with mine also.

    Rather than putting the dial directly in line with the face vent selection I clicked it one notch lower and this seemed to work for me.

  5. #5
    Regular Member byebyeitsagsi's Avatar
    Join Date
    Jun 2008
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    When was the last time you changed the pollen filter also?

  6. #6
    Regular Member
    Join Date
    Nov 2009
    Location
    newcastle
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Check pollen as above that's a very easy fix and cheap.
    Next turn off all noise and change selector position. Move it about and if you hear clicking its the selector servo gone.
    There's a how2 on it somewhere. Dead easy just a tight space behind glove box..

    If its only middle vent the vent, the feed pipe might have been knocked of its connection again trace pope with glove box off, the just a snug click fit pipe so easily knocked out of line.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.2 direct limp home mode
    By noel.nev in forum Engine & Drivetrain
    Replies: 12
    Last Post: 16th April 2010, 14:43
  2. HID's... Pre Face Recommend - NO Hids Direct...
    By Leemarksmith in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 28th March 2010, 12:03
  3. 04 2.2 direct z22yh limp home mode
    By Phil2511 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 25th February 2010, 19:05
  4. 2.2 Direct going into limp mode
    By steviemac74 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 19th January 2010, 23:02
  5. Vectra 2.2SRI Direct Misfire/Limp Mode
    By craig123 in forum Vectra C / Signum Troubleshooting
    Replies: 3
    Last Post: 28th June 2009, 22:28

Visitors found this page by searching for:

vectra c blower weak

vectra c blower not very powerful

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •