User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Signum 2.0T coolant leaking

  1. #1
    Regular Member signum04's Avatar
    Join Date
    Aug 2011
    Location
    High Wycombe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Signum 2.0T coolant leaking

    Hi fellows,

    Wondering if someone could help me please.

    During driving this afternoon, coolant check light comes up on dashboard. I stopped and noticed that some fluid was leaking by driver side front wheel arch. The coolant leaks when engine is running.


    Looking at the car manual, I checked the coolant bottle which was completely empty.

    Please someone guide as I am novice.

    Also any idea, which color coolant is good for Signum 2.0T(04)?

    Many thanks,

    Signum04

  2. #2
    VIP-Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    Failed water pump maybe? All Vec C's require the Orange/Pink/Red OAT antifreeze.

  3. #3
    Regular Member signum04's Avatar
    Join Date
    Aug 2011
    Location
    High Wycombe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks mate, sounds like it as it was only leaking on running engine!

    does any one else have any idea of what could go wrong?

    Cheers

  4. #4
    New Member
    Join Date
    Sep 2008
    Location
    trelewis,south wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Coolant leak on rad

    Quote Originally Posted by signum04 View Post
    Thanks mate, sounds like it as it was only leaking on running engine!

    does any one else have any idea of what could go wrong?

    Cheers
    Check corner of rad,that's where mine was leaking.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. brake fluid leaking signum 3.2v6
    By david106 in forum Suspension, Wheels & Brakes
    Replies: 0
    Last Post: 27th May 2012, 21:25
  2. leaking coolant through thermostat
    By TonyTangles in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 13th January 2012, 16:54
  3. 3.0 cdti y30dt automatic "leaking" coolant
    By Maggie in forum Engine & Drivetrain
    Replies: 2
    Last Post: 13th October 2011, 21:29
  4. Vectra C leaking coolant - please help!
    By d-suhiti91 in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 7th January 2011, 13:58
  5. 3.2 v6 leaking coolant
    By 10PEL in forum Engine & Drivetrain
    Replies: 7
    Last Post: 7th April 2007, 21:29

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •