User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Poor MPG and rough on Shell V power petrol

  1. #1
    Regular Member simac's Avatar
    Join Date
    Sep 2006
    Location
    Wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Poor MPG and rough on Shell V power petrol

    After reading a few threads on here about the high octane shell V power petrol I filled up on some to try it out for myself. It's a 1.8 SRI.

    I wasn't expecting a great increase in performance but I thought it might run a bit better however, MPG was initially down to 27. Even after several motorway trips at 65/70 it will only go to 29 MPG. It's never normally lower than 32 and is often 38/40 on a mway journey.

    Also, it often won't start first time since putting the V stuff in and it isn't running like it normally does. Imaging the accelerator pedal is divided into 3 thirds, it's as though the middle third doesn't do anything !?

    Any ideas ? i'll fill up next time on the normal stuff and hopefully it will be back to normal. I hope that it isn't a coincidence and the start of a problem

  2. #2
    Regular Member Jim Bob's Avatar
    Join Date
    Nov 2006
    Location
    Widnes, Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I whacked a full tank of this in my 2.2direct. (£52!!)

    Didn't notice a performance increase, and MPG was the same - despite it costing more to fill than the cheap stuff from Morrisons.

    I can get about 380-400 miles to a full tank with 'normal fuel' and I achived the same with the V Power.

    Morrisons, miles better value.

  3. #3
    Regular Member simac's Avatar
    Join Date
    Sep 2006
    Location
    Wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Well, I filled up with the normal shell stuff and all seems to be back to normal. It didn't like the V power stuff at all ! I was worried that i'd done it some damage, was like driving a 20 yr old banger

    Running sweet now though PHEW !!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Occasional engine noise, slight rough idle, poor MPG
    By Snizzers in forum Engine & Drivetrain
    Replies: 8
    Last Post: 16th June 2010, 10:44
  2. Shell V-Power
    By azz man in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 25th January 2010, 23:34
  3. Shell V power
    By T4M in forum Vectra C / Signum Car Chat
    Replies: 20
    Last Post: 13th July 2007, 23:59
  4. Shell V Power
    By v6boy in forum Vectra C / Signum Car Chat
    Replies: 43
    Last Post: 23rd January 2007, 20:51
  5. new shell v power
    By david-bell in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 1st September 2006, 20:20

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •