User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: EML on,noisey turbo,really bad smoke,oil light flashing on,please help anyone

  1. #1
    New Member
    Join Date
    Dec 2011
    Location
    ROTHERHAM
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default EML on,noisey turbo,really bad smoke,oil light flashing on,please help anyone

    im a taxi driver with a vectra cdti 1.9 08 reg done 126000 miles,run for months with eml on as problem didnt effect running car,then car developed noisey turbo like a whining,hissing sound that got louder on more revs,i still ran car just easing off throttle to quieten the sound,i did notice that turbo wasnt kicking resulting in slow build up of power.then last night smoke was pouring out of exhaust really bad,cant stress how bad in words.also noticed oil light come on,can anyone comment as i need it back to normal asap thanks,brian

  2. #2
    Regular Member
    Join Date
    Jul 2012
    Location
    Lancs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I'm no expert Brian but, it sounds to me, youve goosed your engine mate. You ran for months with the EML lit and ignored a noisy turbo-as you sow so shall you reap.

  3. #3
    Regular Member
    Join Date
    Aug 2012
    Location
    South Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds to me like your turbo gone mate with the oil seals blown that would chuck a load of oil back into the Inlet and cause the smoke would explain the oil pressure drop and the noise if it is the turbo and you get it repaired make sure the take the intercooler and clean it most prob be full of oil and don't be surprised if when repaired it still smokes for a while as it gonna blow any residual oil through the system will also need to keep an eye on the cat and dpf if you got one

  4. #4
    New Member
    Join Date
    Dec 2011
    Location
    ROTHERHAM
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks guys for ur replies,looks like a trip to the garage tomoz and not sounding cheap after looking at turbo,s on ebay.started it today and starts ok with no smoke but noisey from where turbo is at front,cant run it tho as ive lost all oil somewhere with oil light on.can anyone else give there views or coment please so that i can pass info on as my local garage will fit allsorts to find the cause and bill me acordingly,im already considering if its cheaper to buy another car,thanks brian

  5. #5
    Regular Member DTi Elite's Avatar
    Join Date
    May 2012
    Location
    county durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Elite

    Engine : 1.9 cdti 150

    Year : 2007

    Mileage : 145k

    Default

    sounds like the turbo has failed in a big way , then the engine burnt the oil as it went through the turbo seals

  6. #6
    New Member
    Join Date
    Dec 2011
    Location
    ROTHERHAM
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks for info ive heard this a few times now so guessing i need seals and pump,thanks to all,brian

  7. #7
    Regular Member john norris's Avatar
    Join Date
    Jun 2012
    Location
    lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    you need a new turbo and hope there's no damage from the oil going through your engine

  8. #8
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    33 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mk1 renault scenic... I know I know but it drives

    Trim : Basic

    Engine : 1.6 16v

    Year : 2003

    Default

    New turbo.
    All inter cooler paperwork an exhaust will be flushing

    New oil an filter. An then drop again after couple hundred miles. An you should be ok.

  9. #9
    Regular Member Ben50n's Avatar
    Join Date
    Dec 2011
    Location
    Seaham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Lucky it didnt run away with you, otherwise it could have been much worse.

  10. #10
    New Member
    Join Date
    Dec 2011
    Location
    ROTHERHAM
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    could have done without spending out on a turbo but im confident now its the turbo after reading posts on here,although around 6 months back i had timing belt done and have read that it could be a tensioner thats gone and this could cause smoke and power loss,anyhow im going with turbo and seals,just hope it drives the 3 mile to garage tomoz

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ps3 Red light flashing
    By bigmac in forum Games Room
    Replies: 28
    Last Post: 15th October 2010, 12:42
  2. oil can light flashing
    By jstal40024 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 15th June 2009, 13:10
  3. noisey turbo 2.2dti
    By craigbarlow18 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 18th November 2008, 11:36
  4. flashing light
    By craigmerry in forum Troubleshooting
    Replies: 5
    Last Post: 2nd February 2008, 21:20
  5. Noisey Turbo When Cold ??? 1.9 cdti 150
    By Longtallhowie in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 25th March 2007, 08:55

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •