User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Here we go again

  1. #1
    Regular Member
    Join Date
    Dec 2011
    Location
    newport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SXI

    Engine : 2.2 DTI

    Year : 2003

    Mileage : 105k

    Default Here we go again

    Finally got my 2.2dti running tidy (well for a month)
    sat at traffic lights today everything fine went to pull off and the spanner light comes on with a total loss of power worse than when it used to come on. Restarted engine light was off and back to full power.
    the following codes came up
    P0340 camshaft position sensor circuit malfunction
    p0335 crankshaft sensor circuit range/performance
    B3794 cruise control switch circuit malfunction

    is there any way of cleaning these or will both sensors need changing?
    also where are these sensors located and are they just a case of unplugging the old ones and plugging the new ones in?

    Thanks in advance
    Last edited by paulhb; 12th October 2012 at 17:01.

  2. #2
    Regular Member DTi Elite's Avatar
    Join Date
    May 2012
    Location
    county durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Elite

    Engine : 1.9 cdti 150

    Year : 2007

    Mileage : 145k

    Default

    crank sensor is on the front of the engine , low down at the gearbox end , replace this & hope the cam sensor fault stays off as this is part of the fuel pump .

  3. #3
    Regular Member
    Join Date
    Aug 2012
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    check the wiring harness for shorts and wear too

  4. #4
    Regular Member
    Join Date
    Dec 2011
    Location
    newport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SXI

    Engine : 2.2 DTI

    Year : 2003

    Mileage : 105k

    Default

    cleared the codes and its been fine for a week but tonight it just died on me
    restarted it sounded like a tractor with no power cut out again left it for five
    minutes and it started light out and drove like a dream
    showed cam position sensor crankshaft sensor and now its showing up
    p0149 injection timing control circuit malfunction
    could this be linked to the crank sensor?
    also read a thread in here saying my engine doesnt have a cam sensor is that right?
    Last edited by paulhb; 12th October 2012 at 17:00.

  5. #5
    Regular Member
    Join Date
    Nov 2009
    Location
    newcastle
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If cranksensor knackered it kills the fuel system n won't start when I had bother. Diagnostic said fine on mine and correct info reading. Swopped it and started

  6. #6
    Regular Member
    Join Date
    Dec 2011
    Location
    newport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SXI

    Engine : 2.2 DTI

    Year : 2003

    Mileage : 105k

    Default

    when it was playing up it would turn for ages but not start also it wouldnt bump start
    hopefully i will change it and all will be ok

  7. #7
    Regular Member
    Join Date
    Jun 2009
    Location
    durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Definatey try a crank sensor. Only about £20 and good access as its on the front. Mine developed a similar fault. I was convinced to nearly pay out for a fuel pump.... Glad I didn't and tried a sensor first!

  8. #8
    Regular Member
    Join Date
    Nov 2009
    Location
    newcastle
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine would turn over and would only start with a start spray but wouldn't keep running. Sounds like u know what u need to do. Only wish my garage checked this earlier before they checked injectors and strip pumps down to check.

  9. #9
    Regular Member
    Join Date
    Dec 2011
    Location
    newport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SXI

    Engine : 2.2 DTI

    Year : 2003

    Mileage : 105k

    Default

    just ordered one £18 fingers crossed

  10. #10
    Regular Member
    Join Date
    Aug 2012
    Location
    cardiff
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    did it fix the problem

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •