User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Alternator Problems

  1. #1
    Regular Member
    Join Date
    Jul 2012
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Alternator Problems

    Hey all on the way home tonight the alternator light came on!
    I drive a 54 plate Vectra C 1.9 150 estate and I've tested the battery when running and only get 11.7 so I can see its not charging. I was wondering if there is a fuse or relay that could have gone or is it change the alternator?

    Any help is appreciated!

  2. #2
    Regular Member um20's Avatar
    Join Date
    Mar 2007
    Location
    Doncaster
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Most likely to be the alternator mate, I had the same thing happen to me only last week. If you're handy with a set of spanners and have a few hours spare it's a DIY job, I did mine with the help of the excellent How2 on the site. I had 11.7v at the battery, and the car died on the way home from the folk's house (luckily my Dad was following as we predicted it would die). Once the alt was changed it was showing 13-14v at the battery with engine running.

    Whilst you're at it you might want to consider changing the belt too, it has to come off anyway and it's only £20 (well, mine was). Easy to put on too, damn sight easier than the belt on our Mondy was!

  3. #3
    Regular Member
    Join Date
    Jul 2012
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yeah I though it would be. Luckily I got home! Yeah I will do it myself just spotted the how to it looks like the Astra I had and had to change the alternator on that to! Yeah common practice to change the belt rude not whilst its off.

  4. #4
    Regular Member
    Join Date
    Aug 2012
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just before you do change it get a multi meter and test the voltage coming off the alt. You never know it may be a bad earth causing the battery to not charge.

  5. #5
    Regular Member
    Join Date
    Jul 2012
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    where do you test that?

  6. #6
    Regular Member
    Join Date
    Jul 2012
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sorry which connection on the alternator?

  7. #7
    Regular Member
    Join Date
    Aug 2012
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    on the terminals of the alternator itself. If its around 13.5 v plus then its probably still good. Just put the meter across the two terminals on the back of the alt (or one on the case and one on the positive if it only has one terminal). If you get the higher reading (13.5 plus) when measuring Volt DC then you probably have a bad earth Path. To prove it try clipping a jump start cable from the alternator Negative terminal to the battery neg or from a nice clean bit (maybe sand it clean) of alternator casing to the battery neg and see if the warning goes off. Basically meter goes on the points where the alternator electrically first connects to the rest of the car via wires or its own casing.

  8. #8
    Regular Member
    Join Date
    Jul 2012
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for that I will give that a try in the morning.

  9. #9
    Regular Member
    Join Date
    Aug 2012
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    be sure not to connect the positive to the body of the car (negative) though mate as you will take out the main fuse and maybe worse! Its no more dangerous to do than a jump start this form of testing with a jump cable but just make sure you get it right. Check then recheck :-)

  10. #10
    Regular Member SlowCoach's Avatar
    Join Date
    Jan 2012
    Location
    Houghton Le Spring
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI 150

    Trim : Smart and Bad!

    Engine : Z19DTH

    Year : 2008

    Mileage : 105000

    Default

    Interesting bit i like to know. Where to check for bad earthing point connected to altnerater? As my battery light keeps appearkng 5 minutes of driving but tested fine. Am thinking maybe earth issue.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. alternator problems
    By tyler boy in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 10th November 2011, 19:19
  2. alternator problems
    By webtrawler in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 29th September 2011, 08:09
  3. Alternator problems??
    By chrisvectra in forum Vectra C / Signum Car Chat
    Replies: 27
    Last Post: 13th May 2011, 12:05
  4. alternator problems
    By bran.c in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 20th January 2009, 23:50
  5. Alternator problems
    By AJA in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 27th August 2006, 07:58

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •