User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: Maf sensor

  1. #1
    Regular Member
    Join Date
    Aug 2012
    Location
    South Wales
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Maf sensor

    Been having a bit of trouble with my cdti 150 and according to my dealer he reckons its the maf sensor was just woundering if there a way to clean it/service it as they want over £100 for one any ideas ?

  2. #2
    Regular Member Chunklamb's Avatar
    Join Date
    Jan 2012
    Location
    Milton keynes
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Carb cleaner is probably your best bet.

  3. #3
    Regular Member john norris's Avatar
    Join Date
    Jun 2012
    Location
    lancashire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    carb cleaner take it off give it a good squirt but dont start rubbing cloths and tissue on it its very delicate

  4. #4
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)

    Default

    Electrical contact cleaner

  5. #5
    Regular Member baz2003uk's Avatar
    Join Date
    Mar 2007
    Location
    swindon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    whats the part number on yours as i know they use the same part across allot of the engines
    i am awaiting on a new one myself should be here any time soon just hoping it cures my juddering problem
    if it doesnt i will let you know and send my old one in the post see if that sorts it out

  6. #6
    Regular Member viper8's Avatar
    Join Date
    Mar 2011
    Location
    Northamptonshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Baz

    does your juddering happen at high boost ?
    my signum is playing up
    and i think it is fuel related

  7. #7
    Regular Member baz2003uk's Avatar
    Join Date
    Mar 2007
    Location
    swindon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    na mine seem to between 1500 and 2000 rpm when in above 3rd gear if i boot it it dont happen
    viper same goes with you mate after i have swapped mine out your more than welcome to try my old one if its not faulty

  8. #8
    Regular Member viper8's Avatar
    Join Date
    Mar 2011
    Location
    Northamptonshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    cheers for that
    i will keep that in mind
    hope you get it sorted

  9. #9
    Regular Member baz2003uk's Avatar
    Join Date
    Mar 2007
    Location
    swindon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I am hoping it is faulty as next step is coil packs all six of them £££££
    i take it yours is juddering to what rev range ect is it happening to yours
    over on vxronline it seems coil packs are popular to go on theses then chain (so hoping it not the start of the chains)

  10. #10
    Regular Member john norris's Avatar
    Join Date
    Jun 2012
    Location
    lancashire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    wouldnt coil pack show a EML infact so would the MAF sensor

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 13th August 2012, 22:25
  2. P0141-04 o2 sensor heater circuit open (bank 1 sensor 2)
    By Mark1892 in forum Engine & Drivetrain
    Replies: 12
    Last Post: 3rd August 2012, 09:19
  3. Fitting & Installation of ABS Harness & brake Help sensor sensor
    By Elahi_786 in forum Suspension, Wheels & Brakes
    Replies: 11
    Last Post: 17th April 2012, 20:46

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •