User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: dashboard fault

  1. #1
    Regular Member
    Join Date
    Sep 2012
    Location
    wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default dashboard fault

    hi all wondered if anyone knew any cheap fixes , my clocks go off and battery light comes on i have changed the abs multiplug but its still doing it. they go off for a second then come back on but after 3 times off doing it the dashboard justs goes off until i turn ignition off then back on . its driving me nuts please help thanks

  2. #2
    Regular Member
    Join Date
    Sep 2012
    Location
    wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sorry forgot to say the car is a vectra c sri dti 2.2

  3. #3
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : ls

    Engine : 1800 non vvt

    Year : 2004

    Mileage : 137000

    Default

    do you get no instruments...no speedometer, rev counter, petrol gauge, temp gauage and no warning lights.

    limped home not in limp mode?

  4. #4
    Regular Member
    Join Date
    Sep 2012
    Location
    wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yes all goes off but no lose of power from engine been told to try cim module ?????

  5. #5
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : ls

    Engine : 1800 non vvt

    Year : 2004

    Mileage : 137000

    Default

    Quote Originally Posted by triplecrown31 View Post
    yes all goes off but no lose of power from engine been told to try cim module ?????
    have a look at post 57 it maybe related

    http://www.vectra-c.com/forum/showth...iability/page6

  6. #6
    Regular Member
    Join Date
    May 2010
    Location
    cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine does exactly the same, Has been for months, ****** pain.

  7. #7
    Regular Member
    Join Date
    Sep 2012
    Location
    wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    going to try a cim module , im looking for one with xr code if anyone got one let me know thanks

  8. #8
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    22 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    If only the dash panel is affected, then check the connector on the rear of the cluster.

    It is a 12 pin item, and the connection on the ciruit board can become loose or suffer from dry solder joints.

    I am sure you have been told to check fuses F17 and F12 at the end of the dash panel.
    As well as the ABS connector, CIM connector, earth tags on the steering collumn, and also the cleanliness and security of the main battery connectors.
    Finally battery and alternator condition.

  9. #9
    Regular Member
    Join Date
    Sep 2012
    Location
    wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yes tried all these i plugged in to tech 2 and there where 46 trouble codes most saying no communication to different things , reset them but come back after it loses its signal from cim i think , it turns all instruments on clocks and wipers off,,,, sometimes it puts my headlights on as well when it shuts off doin my head in been told the code i need was only put on police authority vehicles so god knows where i will find one

  10. #10
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    22 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    Head-lights will come on, if the circuit for the lighting switch is disconected - it is a fail safe within the car.
    This is controlled by the BCM, not the CIM.

    Hmm - CIM - have you checked fuse No.10?
    This is the fuse from the CIM, and I wonder if you are getting an intermittent fault with the fuse - loose or dirty fuse.

    Just change this fuse with a new one.

    Now then - if your's is an ex-police car, then there is a possibility that the wiring has been hacked to death - the police mechanics / technicians can be butchers with the wiring when making their own adaptations.
    This has always been the case on earlier Vauxhalls - a total wiring nightmare.

    Just because your's has a police authority specification CIM fitted, doesn't mean you cannot fit a normal specification CIM.
    Your main need, is to find a module to suit your vehicle's set-up.

    Personally - I would have a damn good look at the wiring looms behind the dash, and make good any dodgey or damaged looking wiring.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Dead dashboard.
    By Bob Acid in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 22nd July 2011, 16:29
  2. Replies: 15
    Last Post: 9th July 2011, 22:19
  3. dashboard bit
    By porthy-t in forum Styling
    Replies: 0
    Last Post: 19th January 2010, 19:18
  4. Dashboard Fault
    By RichieClyde in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 25th August 2008, 22:13
  5. Dashboard Damage
    By Cerealuk in forum Vectra C / Signum Car Chat
    Replies: 25
    Last Post: 9th September 2007, 23:12

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •