User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: z20net power lag

  1. #1
    Regular Member richedition100's Avatar
    Join Date
    Dec 2011
    Location
    Shropshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi T Edition 100


    Engine : z20net


    Default z20net power lag

    When giving my car some stick the power seems to bog down between gear changes. Its only been noticeable since changing the injectors and remap. Is this normal on a remapped 2.0 turbo?

  2. #2
    Regular Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    Not at all, it should be much more lively. What injectors and whoes remap have gone with?

  3. #3
    Regular Member richedition100's Avatar
    Join Date
    Dec 2011
    Location
    Shropshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi T Edition 100


    Engine : z20net


    Default

    It was the grey injections that I showed you the pictures of and Midland Remaps came and did the map. I'm going to try and get it on the rollers to see whats going on. Some times I can here the turbo whistle very loud. Not sure if it's loosing boost.

  4. #4
    Regular Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    stick it on a RR and see if its giving you the figures your paid for

  5. #5
    North West Regional Organiser paulvectrac's Avatar
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    36 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    I put money on it overboost
    Vectra vxr custome remaps egr deletes dpf and diagnostic work all remaps are custome bench tuning avalible all genuine equipment PM for info

  6. #6
    Regular Member
    Join Date
    Jun 2008
    Location
    South east
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If it was overboost,wouldn't the boost sensor kick in and stop play?

  7. #7
    North West Regional Organiser paulvectrac's Avatar
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    36 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    Can also make it feel boggy aswell if I ain't bringing boost in propaly
    Vectra vxr custome remaps egr deletes dpf and diagnostic work all remaps are custome bench tuning avalible all genuine equipment PM for info

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra c 2.0t Z20NET low power
    By 2Oturbo in forum Engine & Drivetrain
    Replies: 29
    Last Post: 15th November 2011, 21:23
  2. Problem with z20net Signum loosing power
    By n_hudson in forum Engine & Drivetrain
    Replies: 70
    Last Post: 7th October 2011, 22:41
  3. losing power since remap on z20net
    By signumturbo04 in forum Petrol Engine related
    Replies: 4
    Last Post: 1st May 2011, 16:41
  4. most power out of the z20net
    By vectraturbocal in forum Petrol Engine related
    Replies: 39
    Last Post: 8th November 2010, 20:55
  5. z20net i need more power captain
    By Z20NET in forum Introduce yourself.
    Replies: 6
    Last Post: 5th August 2008, 00:44

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •