User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Urgent helP with 2.0 dti signum

  1. #1
    New Member
    Join Date
    Mar 2011
    Location
    wigan
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Urgent helP with 2.0 dti signum

    Basically I'm an idiot and have killed my car. I went through a flooded roundabout the other day to get to the shops. Went through and all was fine so off I go shopping. On the way back I went through the same flooded roundabout and when the car got out of the water it died within a few yards and I was unable to restart it (wouldn't even turn over). My dad gave me a tow and eventually I got it to fire and it now runs and starts. However I'm getting lots o smoke out of the back and have been for a few days. It stinks of diesel so I think it's overfilling. Drives really lumpy until about 3k then the boost kicks in like a tonne o bricks. (doesn't seem to smoke when in boost). I thought id hydrolic'd the engine but once it's in boost it runs smooth as always. Ive toyed a new egr valve and it just made the car feel quicker buys didn't go the smoke or the lumpy driving. I think it's boost related but I'm not sure. Any advice greatly appreciated.

  2. #2
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)

    Default

    give it a full service.

    no knocks or anything? brave towing it after it cut out after a puddle you risked damged con rons if it had hydroliked

  3. #3
    New Member
    Join Date
    Mar 2011
    Location
    wigan
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    It had a full service a few months ago. I thought I the engine had hydrolic'd it was a bin job anyway so I just went for it. There's a slight diesel knock at low revs but if I had ******ed a to or a valve it would be knackered throughout the rev range. To me it's Pouring diesel in thinking its on boost an running it rich an lumpy. Then at 2.7-3k rpm boost kicks in hard then all is well. Usually the boost kicks in at about 2k I think and you can't feel it. This you can feel. I was thinking an air leak and it's loosing boost pressure until 3k and then enough air is finally getting to the turbo to spin it up. But I dunno how water would have caused a leak

  4. #4
    Regular Member john norris's Avatar
    Join Date
    Jun 2012
    Location
    lancashire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    id be tempted to look round crank sensor ect see if theres any crap got stuck in there, happened to me once going through a flood (vec b) knocked the sensor back just far enough for it not to sense properly i didnt get a warning light because it was intermittent or so i was told

  5. #5
    Regular Member DTi Elite's Avatar
    Join Date
    May 2012
    Location
    county durham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    my guess is a slightly bent con rod .

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Urgent help needed, more signum problems :(
    By Shogun in forum Troubleshooting
    Replies: 23
    Last Post: 29th September 2012, 20:45
  2. Urgent Help Needed please, Signum Elite 2.0T CIM/Dash/Electrical Problems!!!!!
    By robs_gsi in forum Electrical & ICE (including SatNav)
    Replies: 13
    Last Post: 28th April 2012, 10:43
  3. Urgent advice - Signum 1.9cdti clutch smell
    By pscocoa in forum Engine & Drivetrain
    Replies: 13
    Last Post: 2nd August 2008, 11:41
  4. urgent help needed re signum and dealer
    By merikiito in forum Handling & Braking
    Replies: 9
    Last Post: 10th January 2008, 01:13
  5. Signum Front Fog Lamps..urgent Help Needed!
    By CARRERA in forum Bodywork & Interior
    Replies: 14
    Last Post: 5th September 2007, 08:51

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •