User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Signum Blower Woes - Fuse Replaced...still broken :(

  1. #1
    Regular Member
    Join Date
    Aug 2012
    Location
    Rugby, Warks
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Signum Blower Woes - Fuse Replaced...still broken :(

    So, I bought a Signum a couple of weeks ago and noticed that the blower only works on number 4 setting. After a bit of googling i managed to find the solution to this common problem on this excellent forum.

    I removed the glovebox, followed by the resistor pack, and ventured to Maplin to find a replacement thermal fuse. The helpful chap promptly found one for me, and I screwed it in, plugged the connector back in, and switched the fan on to find....
    It still didn't work!

    Where do I go from here? The new fuse has continuity (as does the old one, so it would appear).

    Do i need a new resistor pack or does the problem lie elsewhere?

    Thanks in advance!
    James

  2. #2
    Full Member
    Join Date
    Oct 2008
    Location
    midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hello

    Exactly the same happened with me - 2 years ago thermal fuse blew replaced and all was well - 2 months ago went again replace the fuse, not working so had to buy a resistor pack of ebay for a tenner - now works. I think the electrics just stop working and need to be replaced

  3. #3
    Regular Member
    Join Date
    Aug 2012
    Location
    Rugby, Warks
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by steve533 View Post
    Hello

    Exactly the same happened with me - 2 years ago thermal fuse blew replaced and all was well - 2 months ago went again replace the fuse, not working so had to buy a resistor pack of ebay for a tenner - now works. I think the electrics just stop working and need to be replaced
    Ah, i was wondering if that could be the case. both fuses are fine. so you just replaced the whole green resistor pack and it worked again?

  4. #4
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : ls

    Engine : 1800

    Year : 04

    Mileage : 127000

  5. #5
    Regular Member
    Join Date
    Aug 2012
    Location
    Rugby, Warks
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks, sounds like a good job for the weekend.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Signum Blower/Fan Only Works on Speed 4
    By Gayno in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 15th April 2012, 13:31
  2. 2.0 T signum lambda woes
    By Rasher in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 9th April 2012, 18:40
  3. Heater blower replaced
    By jonny747 in forum Troubleshooting
    Replies: 2
    Last Post: 18th May 2011, 17:09
  4. Should Vauxhall Pay For Replaced Blower and/or Resistor Packs
    By iandavis in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 27th August 2010, 11:52
  5. Signum woes
    By Hs2300 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 3rd March 2009, 22:51

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •